Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при вызове метода контекста PreviewFile1C

Ошибка при вызове метода контекста PreviewFile1C
Я
   zerat
 
03.03.20 - 08:50
Всем привет! Бухгалтерия предприятия  2.0 (2.0.66.99). В регламентированном отчете Декларация 3-НДФЛ когда нажимаю показать бланк формы с двухмерным штрихкодом выходит данная ошибка
"Ошибка при вызове метода контекста PreviewFile1C", самое интересное в том что в таком же отчете за 2018 год все ок, проблема только в 2019 версии отчета.
Проверял наименование налогового органа, в 1С оно указано, но в коде не заполняется, нашел уже код вывода

    Если ТаксДокПринт <> Неопределено Тогда
        Попытка
            ТаксДокПринт.PrintTiffFolder = ВремКаталог;
            НаименованиеИФНС = ОпределитьНаименованиеИФНСПолучателяОтчета(Форма);
            
            Если ЗначениеЗаполнено(НаименованиеИФНС) Тогда
                ТаксДокПринт.SetPrintTiffParam1C("Наименование налогового органа-получателя", НаименованиеИФНС);
            КонецЕсли;
            Если ИмяКнопки = "ПечататьМашиночитаемыйБланк" Тогда
                ТаксДокПринт.PrintFile(ВремФайл, "", "", 0);
            Иначе
                ТаксДокПринт.PreviewFile1C(ВремФайл, 0);
            КонецЕсли;
            Результат = Истина;
        Исключение
            ОбработатьОшибкуМодуляПечати(ИнформацияОбОшибке().Описание);
            ТаксДокПринт = Неопределено;
            Результат = Ложь;
        КонецПопытки;
    КонецЕсли;

На этой строке ТаксДокПринт.PreviewFile1C(ВремФайл, 0); выходит ошибка

Может знает кто нить что можно еще сделать? Проблема в конкретном виде отчета
 
 
   zerat
 
1 - 03.03.20 - 14:44
ап ап
   Ц_У
 
2 - 03.03.20 - 14:46
Отладчик что говорит о ВремФайл?
   zerat
 
3 - 03.03.20 - 17:11
(2) обычный файл, смотрел его, внешне проблем не увидел
   Йохохо
 
4 - 03.03.20 - 17:44
(3) какая сборка линукс и х32 или х64?
   zerat
 
5 - 03.03.20 - 17:45
(4) винда 10 х64, дело не в сборе а в отчете именно, писал что такой же отчет от 2018 года норм всё и остальные отчеты тоже
   Йохохо
 
6 - 03.03.20 - 17:46
(5) винда ладно, а 1с х32 или х64?
   zerat
 
7 - 03.03.20 - 17:48
(6) 32
   Tatitutu
 
8 - 03.03.20 - 18:05
В отчете Настройки - снять галочку печать PDF147 и распечатай без него
это на 1 только отчете валится (предлагает обновить комппоненту - но все без толку)
   zerat
 
9 - 03.03.20 - 18:32
(8) надо с ней именно

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.