Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подключение USB сканера в УТП

Подключение USB сканера в УТП
Я
   Dedushka
 
02.03.20 - 18:20
Привет всем.
Подключаю сканер к УТП, платформа 8.3.12 обычные формы.
Установил драйвер USB-com, настроил сканер, подключил обработку, все работает, тест проходит, штрихкод сканирует, внешнее событие отрабатывает, но в этом месте в обработке ТО сервер не проходит проверку:
Если ТекСобытие.Источник = Источник
ТекСобытие.Источник = "1ССканерШтрихКодаc73c0b16-c73c-45b5-a6ff-b5b545a79ba3"
Источник = "Сканер штрихкода"
Кто-то сталкивался с таким?

Функция ОбработатьВнешнееСобытие(Источник, Событие, Данные, Клиент) Экспорт

    Результат = мНетОшибки;

    Клиенты = ПолучитьПараметрСервераТО("Клиенты", "Соответствие");
    События = Клиенты[Клиент];
    Если События <> Неопределено Тогда
        Для Каждого ТекСобытие Из События Цикл
            Если ТекСобытие.Источник   = Источник
               И ТекСобытие.ИмяСобытия = Событие Тогда
                Оборудование = ПолучитьПараметрСервераТО("Оборудование",    "ТаблицаЗначений");
                ТО           = Оборудование.Найти(ТекСобытие.Идентификатор, "Идентификатор");
                ВидТО        = ТО.Вид;
                Обработка    = ТО.Обработка;
                Объект       = ТО.Объект;
                Результат = ОбработатьВнешнееСобытиеВнутр(ВидТО, Обработка, Объект,
                                                          Клиент, Событие, Данные,
                                                          ТекСобытие.Идентификатор);
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;

    Возврат Результат;

КонецФункции
   Сияющий в темноте
 
1 - 02.03.20 - 19:17
обработка и компонента разных версий.
ид добавили,чтобы можно было подключить два разных сканера,не натыкаясь на грабли.
   Dedushka
 
2 - 03.03.20 - 11:36
(1) Так можно просто закоментировать это условие?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.