Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Динамический список УПП

Динамический список УПП
Я
   FransisDrake
 
02.03.20 - 12:13
Добрый день, коллеги!
Такой вопрос, УПП 1.3, на управляемой форме создал динамический список, и добавил параметр.
При открытии, автоматически подставляется текущий пользователь, но при изменении, данные в динамическом списке не обновляются.
&НаСервере
Процедура ИсполнительПриИзмененииНаСервере()
    Элементы.дс.Обновить();
КонецПроцедуры

&НаКлиенте
Процедура ИсполнительПриИзменении(Элемент)
    ИсполнительПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Исполнитель  = ПользователиКлиентСервер.ТекущийПользователь();
    дс.Параметры.УстановитьЗначениеПараметра("Исполнитель", Исполнитель);
КонецПроцедуры
 
 
   Ns33
 
1 - 02.03.20 - 12:27
Обновить() не надо, там должен быть код который у тебя в ПриСозданииНаСервере() сейчас.
   FransisDrake
 
2 - 02.03.20 - 12:36
(1) Не сработало..




&НаСервере
Процедура ИсполнительПриИзмененииНаСервере()
        Исполнитель  = Справочники.Пользователи;
    дс.Параметры.УстановитьЗначениеПараметра("Исполнитель", Исполнитель);; 
КонецПроцедуры

&НаКлиенте
Процедура ИсполнительПриИзменении(Элемент)
    ИсполнительПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Исполнитель  = ПользователиКлиентСервер.ТекущийПользователь();
    дс.Параметры.УстановитьЗначениеПараметра("Исполнитель", Исполнитель);
КонецПроцедуры
   catena
 
3 - 02.03.20 - 12:40
(2)Справочники.Пользователи и ПользователиКлиентСервер.ТекущийПользователь() - обычно очень и очень разные типы.
   catena
 
4 - 02.03.20 - 12:41
Изменение кого и где не приводит к изменению в списке?
   Ns33
 
5 - 02.03.20 - 12:43
(2) не то в параметр передаешь. Там должен быть либо реквизит формы, напр ВыбИсполнитель, либо реквизит объекта, напр. Объект.ВыбИсполнитель.
   FransisDrake
 
6 - 02.03.20 - 12:48
(5) Точно! Спасибо! Передал Объект.Исполнитель, и заработало!

И еще вопросик. Как сделать, чтобы при двойной щелчке по строчке из динамического списка, открывалась именно это задача?
   catena
 
7 - 02.03.20 - 12:50
(6)Сделать таблицу задач основной для ДС.
   Ns33
 
8 - 02.03.20 - 12:54
(6) Определяшь событие "Выбор" для ДС, там

ТД=Элементы.Список.ТекущиеДанные;
ПоказатьЗначение(,ТД.ИмяНужногоРеквизитаКоторыйНадоОткрыть);
   FransisDrake
 
9 - 02.03.20 - 13:31
(8) ПоказатьЗначение(,ТД.ИмяНужногоРеквизитаКоторыйНадоОткрыть); - не совсем понял
   FransisDrake
 
10 - 02.03.20 - 13:44
(8) Например, Автора надо открыть:
ТД=Элементы.Список.ТекущиеДанные;
ПоказатьЗначение(,ТД.Автор);

Я явно что-то делаю не так
   FransisDrake
 
11 - 03.03.20 - 07:26
Добрый день!
Подскажите пожалуйста, у меня сложный запрос, то есть основную таблицу выбрать нельзя. Как мне при дабл клике по полю в динамическом списке, провалиться в него?
   FransisDrake
 
12 - 03.03.20 - 08:15
Хелп, ай нид сомбааади
   catena
 
13 - 03.03.20 - 08:46
Что не получилось в (10)?
   FransisDrake
 
14 - 03.03.20 - 08:51
(13) все получилось, я просто не очень умный -_-
Разобрался! Всем спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.