Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Изменение прдставления реквизита подразделениек только в док заявка

Изменение прдставления реквизита подразделениек только в док  заявка
Я
   pedagog
 
02.03.20 - 11:52
необходимо изменить прдставление реквизита подразделение только в док  заявка (наименование+ родитель). для остальных документов оставить прежнее представление.  Управляемые формы
   pedagog
 
1 - 02.03.20 - 12:08
Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    НаименованиеГорода = "";
    Если Данные.Ссылка <> Неопределено Тогда
        СтандартнаяОбработка = Ложь;
        текПодразделение = Данные.Ссылка.родитель;
        пока ЗначениеЗаполнено(текПодразделение.родитель) цикл
             текПодразделение = текПодразделение.родитель;
        КонецЦикла;
        Представление = СокрЛП(Данные.Ссылка.Наименование)+", "+СокрЛп(текПодразделение);
    
    КонецЕсли;
КонецПроцедуры

вот процедура. все работает. но как сделать, чтобы такое представление выводилось только в док заявка?
   pedagog
 
2 - 02.03.20 - 12:12
народ, не проходите мимо. помогите
   Йохохо
 
3 - 02.03.20 - 12:17
изменить док заявка
500р
   D_E_S_131
 
4 - 02.03.20 - 12:22
"но как сделать, чтобы такое представление выводилось только в док заявка?" - использовать этот код только для модуля менеджера документа "док заявка". Если я правильно понял, что "док заявка" это вид документа.
   FIXXXL
 
5 - 02.03.20 - 13:00
ТипЗнч(Данные.Ссылка)
   FIXXXL
 
6 - 02.03.20 - 13:01
(5) + сорри, не то :)
   FIXXXL
 
7 - 02.03.20 - 13:03
(1) но такой код в продакшн пихать не стОит, тормоза - гарантированны
   FIXXXL
 
8 - 02.03.20 - 13:07
лучше создай реквизит справочника или доп.реквизит и в подписке ПередЗаписью юзай функцию ПолноеИмя(), результат парси и пиши в реквизит
в форме же документа можешь хоть через УсловноеОформление делать, хоть через гиперссылку...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.