Вход | Регистрация
 

поле подразделение должно быть пустым

поле подразделение должно быть пустым
Я
   golem14
 
02.03.20 - 09:44
при записи проводок выходит ошибка "поле подразделение должно быть пустым".
вставил такой код:
    Для каждого Запись ИЗ Источник Цикл
        Если НЕ Запись.СчетДт.УчетПоПодразделениям Тогда
            Запись.ПодразделениеДт = Неопределено;
        КонецЕсли;
        Если НЕ Запись.СчетКт.УчетПоПодразделениям Тогда
            Запись.ПодразделениеКт = Неопределено;
        КонецЕсли;
    КонецЦикла;

Но я не уверен что туда нужно писать Неопределено, может быть лучше Null, или пустую ссылку?
 
 
   Kigo_Kigo
 
1 - 02.03.20 - 09:45
Запись.ПодразделениеДт = ""; не прокатывает?
   golem14
 
2 - 02.03.20 - 09:46
(1) все перечисленные варианты прокатывают, вопрос в том как правильнее?
   Kigo_Kigo
 
3 - 02.03.20 - 09:51
(2) И так и так ЗначениеЗаполнено(Значение) будет выдавать ложь
   Фрэнки
 
4 - 02.03.20 - 09:56
Я бы оставил Неопределено
так лучше видно, что оно действительно не должно быть определено
   Флориан
 
5 - 02.03.20 - 10:03
Запись.ПодразделениеКт = Справочник.Подразделение.ПустаяСсылка(); - так тип сохранится
   Фрэнки
 
6 - 02.03.20 - 10:05
(5) только я не помню с пылу с жару - возможно, что не всегда это хорошо, что в ПодразделениеКт будет установлен какой-то тип.
   Kigo_Kigo
 
7 - 02.03.20 - 10:18
(5) (6) если там уже определенно что это Справочник.Подразделение , то при любом раскладе там будет Справочник.Подразделение.ПустаяСсылка(); 
Если тип не определен и его надо переопределять программно, то есть ли смысл определять его как Справочник.Подразделение.ПустаяСсылка(); ?
   StanLee
 
8 - 02.03.20 - 10:54
(0) 1. введи операцию вручную по этому счету
2. запиши проводки вот эти туда куда ты их записываешь
3. в оборотке по этому счету посмотри, не появились ли дубли подразделений
   catena
 
9 - 02.03.20 - 11:05
(7)Зависит от того, как оно в коде проверяет. Если на ЗначениеЗаполнено - это одно. А если на равенство пустой ссылке - другое.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.