Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отображение поля формы для табличного документа

Отображение поля формы для табличного документа
Я
   Demonius
 
28.02.20 - 13:59
Добрый день,
Платформа 8.3.13.1690.
1) Назначаю имена строкам и колонкам табличного документа:
Процедура ДобавитьИменаСтрокИСтолбцов(ТД) Экспорт
    Для НомерСтроки = 1 По ТД.ВысотаТаблицы Цикл
        ТД.Область(НомерСтроки, 0, НомерСтроки).Имя = "С" + НомерСтроки;        
    КонецЦикла;
    Для НомерКолонки = 1 По ТД.ШиринаТаблицы Цикл
        ТД.Область(0, НомерКолонки, 0, НомерКолонки).Имя = "К" + НомерКолонки;        
    КонецЦикла
КонецПроцедуры    
2) Вывожу этот табличный документ (ТД) управляемой форме, предварительно установив свойство поля формы  Элементы.Макет.ОтображатьИменаСтрокИКолонок = Истина
При отображении в форме имена строк отображаются, а отображения имен колонок НЕТ.

Может у уважаемых коллег есть соображения?
Спасибо.
   D_E_S_131
 
1 - 28.02.20 - 14:08
Может картинку покажешь как у тебя и что отображается?
   Demonius
 
2 - 28.02.20 - 14:24
Не подскажете. как картинку здесь добавить ?
   Demonius
 
3 - 28.02.20 - 14:25
   D_E_S_131
 
4 - 28.02.20 - 15:05
А само свойство "ОтображатьЗаголовки" у элемента формы включено?
   Demonius
 
5 - 28.02.20 - 15:35
D_E_S_131, спасибо за потраченное время.
Тут проблема решилась изменением   
ТД.Область(0, НомерКолонки, 0, НомерКолонки).Имя = "К" + НомерКолонки;      

                                  НА

ТД.Область(0, НомерКолонки, ТД.ВысотаТаблицы, НомерКолонки).Имя = "К" + Строка(НомерКолонки);

Т.е. проблема с отображением была из-за того, что я не указал в 3-м аргументе номер строки, из которого 1С могла бы получить информацию о ширине колонки.
Еще раз спасибо.
   Demonius
 
6 - 28.02.20 - 15:38
Иногда мне кажется. что уровень входа в 1С очень высок из-за слишком запутанной, неточной, неполной документации и кучи глюков.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.