Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

программно задать тип поля выбора

программно задать тип поля выбора
Я
   BazCATilio
 
28.02.20 - 12:47
Всем доброго времени суток!



В обработке есть поле выбора ЕдИзм .

Подскажите, как программно указать тип поля в зависимости от версии конфигурации(ут и розница)?

То есть нужно, чтобы в ут поле принимало тип Справочники.ЕдиницыИзмерения, а в рознице - Справочники.БазовыеЕдиницыИзмерения


&НаСервере
Функция ВерсияКонфы()
    
    ИмяКонфы = Метаданные.Имя;
    
    возврат ИмяКонфы;
    
КонецФункции



&НаКлиенте
Процедура ЕдИзмПриИзменении(Элемент)

Если ВерсияКонфы="Розница" тогда

   ТипЕд = Новый ОписаниеТипов("СправочникСсылка.БазовыеЕдиницыИзмерения");// хз как сделать
   Элементы.ЕдИзм.Значение = ТипЕд.ПривестиЗначение(ЕдИзм);

иначеЕсли ВерсияКонфы="УправлениеТорговлей" Тогда


КонецЕсли;
КонецЕсли;






p.s. 1с 8.3 УФ
   goodprog
 
1 - 28.02.20 - 12:48
Приравнять к пустой ссылке
   vicof
 
2 - 28.02.20 - 12:48
ПредопределенноЗначение("Справочниким.БазовыеЕдиницыИзмерения.ПустаяСсылка")
   BazCATilio
 
3 - 28.02.20 - 13:00
всем спасибо)

вот так заработало:

ПредопределенноеЗначение("Справочник.БазовыеЕдиницыИзмерения.ПустаяСсылка");
   malem13
 
4 - 28.02.20 - 13:11
а если очистить поле тип не слетит?
   BazCATilio
 
5 - 28.02.20 - 15:03
слетит, но выбираешь в диалоговом окне его и все

а чтоб сразу в поле тип выбирался, хз как сделать
   malem13
 
6 - 28.02.20 - 16:25
можно дописать обработчик при изменении :)
   BazCATilio
 
7 - 28.02.20 - 17:52
(6) а как это реализовать?
   NurSagen
 
8 - 28.02.20 - 19:22
задать произвольный тип, а при начале выбора делать ограничение типа
   palsergeich
 
9 - 28.02.20 - 19:30
Поле.ОграничениеТипа

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.