Вход | Регистрация
 

БП 3.0 "В данной процедуре / функции не был установлен безопасный режим"

БП 3.0 "В данной процедуре / функции не был установлен безопасный режим"
Я
   Niang
 
28.02.20 - 12:23
Добрый день! После обновления не запускается бухгалтерия 3.0. Текущая версия 72.70. Ошибка в процедуре ПроверитьВозможностьЗапуска,  при вызове процедуры УстановитьБезопасныйРежим(Ложь). Полный текст ошибки:

{ОбщийМодуль.СтандартныеПодсистемыСервер.Модуль(3125)}: Ошибка при вызове метода контекста (УстановитьБезопасныйРежим)
        УстановитьБезопасныйРежим(Ложь);
по причине:
В данной процедуре/ функции не был установлен безопасный режим
В данной процедуре/ функции не был установлен безопасный режим

База серверная, тестирование/кэш не помогло.
 
 
   vicof
 
1 - 28.02.20 - 12:26
Криво обновили? Платформа не свежая?
   Niang
 
2 - 28.02.20 - 12:27
(1) платформа свежая. Обновилась видимо криво, раз после обновления не запускается
   pechkin
 
3 - 28.02.20 - 12:27
можно злепуху сделать.
если БезопасныйРежим() Тогда УстановитьБезопасныйРежим(Ложь); КонецЕсли

   Niang
 
4 - 28.02.20 - 12:31
(3) а в чем смысл? Вроде бы в типовом варианте тоже самое.
   Niang
 
5 - 28.02.20 - 12:32
Если БезопасныйРежим() <> ПрофильИнформационнойБазы Тогда
            
            // Профиль ИБ не доступен для выполнения обработчиков.

            
            УстановитьБезопасныйРежим(Ложь);
            
            Попытка
                ДоступенПривилегированныйРежим = ВозможноВыполнениеОбработчиковБезУстановкиБезопасногоРежима();
            Исключение
                ДоступенПривилегированныйРежим = Ложь;
            КонецПопытки;
                
            Если Не ДоступенПривилегированныйРежим Тогда
                ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                    НСтр("ru = 'Невозможно установить параметры сеанса по причине: профиль безопасности %1 отсутствует в кластере серверов 1С:Предприятия, или для него запрещено использование в качестве профиля безопасности безопасного режима.
                        |
                        |Для восстановления работоспособности программы требуется отключить использование профиля безопасности через консоль кластера и заново настроить профили безопасности с помощью интерфейса конфигурации (соответствующие команды находятся в разделе настроек программы).'"),
                    ПрофильИнформационнойБазы);
            КонецЕсли;
            
        КонецЕсли;
   vicof
 
6 - 28.02.20 - 12:49
"Для восстановления работоспособности программы требуется отключить использование профиля безопасности через консоль кластера и заново настроить профили безопасности с помощью интерфейса конфигурации (соответствующие команды находятся в разделе настроек программы)"
Что непонятного?
   Niang
 
7 - 28.02.20 - 13:14
(6) ошибка описана в первом сообщении. Никаких профилей безопасности не используется
   pechkin
 
8 - 28.02.20 - 17:22
что в отладчике говорит БезопасныйРежим() и ПрофильИнформационнойБазы

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.