Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подскажите про функции

Подскажите про функции
Я
   example221
 
26.02.20 - 17:54
Добрый вечер форумчане,я вызываю печать вот так
ДокСчетНаОплату.Печать("СчетНаОплату",1,Ложь,);
для примера
как мне приказать ей делать масштабирование по ширире
 
 
   vicof
 
1 - 26.02.20 - 17:55
Установить параметр табличного документа
   vicof
 
2 - 26.02.20 - 17:56
Точней свойство
   craxx
 
3 - 26.02.20 - 17:56
(0) как-то так
ПриказатьДелатьМасштабированиеПоШирине=Истина;
ДокСчетНаОплату.Печать("СчетНаОплату",1,Ложь,ПриказатьДелатьМасштабированиеПоШирине);
   example221
 
4 - 27.02.20 - 08:28
Пытался сообщает много фактических пораметров
   Волшебник
 
Модератор
5 - 27.02.20 - 08:35
Лучше так:

СтрогоПриказатьДелатьМасштабированиеПоШирине=Истина;
ДокСчетНаОплату.Печать("СчетНаОплату",1,Ложь,СтрогоПриказатьДелатьМасштабированиеПоШирине);

а в процедуре Печать в модуле менеджера сделать проверку

Если СтрогоПриказатьДелатьМасштабированиеПоШирине Тогда
   ТабДок.АвтоМасштаб = Истина;
КонецЕсли;
   CaIIIka
 
6 - 27.02.20 - 08:59
(0) Можно в процедуре печать документа счет прямо установить "ТабДок.АвтоМасштаб = Истина;". Без доп. параметров. Так будет всегда и для всех.
(4) Если придерживаться (1-5), то в процедуре Печать документа Счет придется добавить еще один параметр, лучше имеющий значение по-умолчанию. Напр. ....., СтрогоПриказатьДелатьМасштабированиеПоШирине = Истина)

Если печатная форма документа выводится через специально созданную форму для печати документов, то контролировать параметры печати придется и в ней.
   example221
 
7 - 27.02.20 - 09:01
(5) звучит как очень хороший план щас попробую
   example221
 
8 - 27.02.20 - 09:08
(5) (это в модуле объекта куда меня кидает при ф12 по печать)
Функция Печать(НазваниеПечатнойФормы="", КоличествоЭкземпляров=0, НаПринтер=Ложь, Документ=Неопределено, АвтоМасштаб =Истина) Экспорт
        Возврат дкПечать(ЭтотОбъект, НазваниеПечатнойФормы, КоличествоЭкземпляров, НаПринтер, Документ, АвтоМасштаб);
    КонецФункции// Печать()


(Это общий модуль дкДокументы)
Функция дкПечать(ЭтотОбъект, НазваниеПечатнойФормы="", КоличествоЭкземпляров=0, НаПринтер=Ложь, Документ=Неопределено) Экспорт
    Возврат зфПечать(ЭтотОбъект, НазваниеПечатнойФормы, КоличествоЭкземпляров, НаПринтер, Документ);
КонецФункции// дкПечать()


(а это защитные методы общий)
Функция зфПечать(ЭтотОбъект, НазваниеПечатнойФормы, КоличествоЭкземпляров, НаПринтер, Документ) Экспорт
    ОбработкаЗащиты = "";

    Если Не зфПроверкаЗащиты(ОбработкаЗащиты) Тогда
        Возврат Ложь;
    КонецЕсли;

    пЭтотОбъект = ЭтотОбъект;
    пНазваниеПечатнойФормы = НазваниеПечатнойФормы;
    пКоличествоЭкземпляров = КоличествоЭкземпляров;
    пНаПринтер = НаПринтер;
    пДокумент = Документ;
    СисИнфо = Новый СистемнаяИнформация;
    версияСтрока = СисИнфо.ВерсияПриложения;
    версиячисло = 0;
    ч = лев(версияСтрока,НАЙТИ(версияСтрока,".")-1);
    версиячисло = версиячисло+ЧИСЛО(Ч)*1000000;
    версияСтрока = СРЕД(версияСтрока,НАЙТИ(версияСтрока,".")+1);
    ч = лев(версияСтрока,НАЙТИ(версияСтрока,".")-1);
    версиячисло = версиячисло+ЧИСЛО(Ч)*1000;
    версияСтрока = СРЕД(версияСтрока,НАЙТИ(версияСтрока,".")+1);
    ч = лев(версияСтрока,НАЙТИ(версияСтрока,".")-1);
    версиячисло = версиячисло+ЧИСЛО(Ч);
    версияСтрока = СРЕД(версияСтрока,НАЙТИ(версияСтрока,".")+1);
    версиячисло = версиячисло+ЧИСЛО(версияСтрока)/1000;
    Если версиячисло<8002000 Тогда
        Рез = ОбработкаЗащиты.Компонента.зфПечать(пЭтотОбъект, пНазваниеПечатнойФормы, пКоличествоЭкземпляров, пНаПринтер, пДокумент, );
    Иначе
        Рез = бМоиФункции._зфПечать(пЭтотОбъект, пНазваниеПечатнойФормы, пКоличествоЭкземпляров, пНаПринтер, пДокумент, );
    КонецЕсли; 
    КоличествоЭкземпляров = пКоличествоЭкземпляров;
    НаПринтер = пНаПринтер;
    Документ = пДокумент;    
    Возврат Рез;
КонецФункции

Волшебник,я чуть потерялся,можешь пожалуйста еще чуть навести

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.