Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Добавил печать (программно) в спр., кнопка печати по умолч. серым цветом из-за чего?

Добавил печать (программно) в спр., кнопка печати по умолч. серым цветом из-за чего?
Я
   SkillUp
 
26.02.20 - 12:11
Здравствуйте, добавил печать (программно) в спр., кнопка печати по умолч. серым цветом из-за чего? Ситуация на фото - https://drive.google.com/open?id=1WIvCU__SDmpVHRpcUmedzBGgtd87wD1N

Мой код:
В Форме элемента:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    
    // Установка кнопок печати
    УстановитьКнопкиПечати();

КонецПроцедуры

//Процедура устанавливает подменю "Печать" и кнопку "Печать по умолчанию" при необходимости
//
Процедура УстановитьКнопкиПечати()
    
    мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, ПолучитьСтруктуруПечатныхФорм(), Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));
    
    УниверсальныеМеханизмы.УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
    УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));
    
    Если Не мПодменюПечати = Неопределено Тогда
        УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
    КонецЕсли;     

КонецПроцедуры

В модуле объекта:

Функция ПолучитьСтруктуруПечатныхФорм() Экспорт
    
    Возврат Новый Структура;
    
КонецФункции // ПолучитьСтруктуруПечатныхФорм()

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.