Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Экспорт в CSV

Экспорт в CSV
Я
   Antoha18rus
 
25.02.20 - 21:05
Работающий код для экспорта в csv

&НаСервере
Процедура ВыгрузитьНаСервере()
    
КонецПроцедуры

&НаКлиенте
Процедура Выгрузить(Команда) //кнопка
    ВыгрузитьВCSV("D:\Nomenklatura.csv");
КонецПроцедуры

Процедура ВыгрузитьВCSV(имяФайлаCSV);
          Разделитель = ";";
          ТаблицаЗначений = Получитьданные();
          Текст = СоздатьДанныеCSV(ТаблицаЗначений,разделитель);
          ЗаписатьCSV(текст,имяФайлаCSV);
КонецПроцедуры

Функция Получитьданные()          
            Запрос = Новый Запрос;
            Запрос.Текст =
                       "ВЫБРАТЬ
                       |    Имена.Код,
                       |    Имена.Наименование
                       |ИЗ
                       |    Справочник.Имена КАК Имена";         
            РезультатЗапроса = Запрос.Выполнить().Выгрузить();  
            Возврат РезультатЗапроса;
КонецФункции

Функция СоздатьДанныеCSV(ТаблицаЗначений,разделитель)
Текст="";
для каждого запись из ТаблицаЗначений Цикл
              
Текст = Текст + запись.Код + разделитель + запись.Наименование + Символы.ПС;             
КонецЦикла;
Возврат текст;
КонецФункции

Процедура ЗаписатьCSV(текст,имяФайла)                     
          кодировка = КодировкаТекста.ANSI;
          ТекстовыйФайлЗапись = Новый ЗаписьТекста(имяФайла,Кодировка);          
          ТекстовыйФайлЗапись.ЗаписатьСтроку(текст);
          ТекстовыйФайлЗапись.Закрыть();             
КонецПроцедуры
   Garykom
 
1 - 25.02.20 - 21:20
(0) Что будет если в данных будет ";"  ?

Или еще хуже Символ(10) и Символ(13) ?
   acht
 
2 - 26.02.20 - 09:49
(0) Ты можешь поднять настроение этому форуму, если будешь добавлять в начало своих новых постов фразу: "мой гений дарит вам"
   mikecool
 
3 - 26.02.20 - 09:58
(0) прелестно... прелестно!!!! (с) ворона
   GROOVY
 
4 - 26.02.20 - 10:14
Нет директив компиляции, первая процедура пустая. КГ/АМ.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.