Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Импорт картинки в 1С

Импорт картинки в 1С
Я
   Antoha18rus
 
25.02.20 - 20:16
Кому нужен пример импорта картинки в 1С

&НаКлиенте
Процедура ВыбратьЛоготип(Команда) // это кнопка
    //Создаем оповещение, именно процедура "ОбработатьВыборФайла" будет вызвана при закрытии окна выбора файла
    Оповещение = Новый ОписаниеОповещения("ОбработатьВыборФайла", ЭтотОбъект);
    
    //Открываем интерактивно окно для выбора файла
    НачатьПомещениеФайла(Оповещение, , , Истина, УникальныйИдентификатор);
КонецПроцедуры

&НаКлиенте
Процедура ОбработатьВыборФайла(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
    
    Если Не Результат Тогда
        Возврат;
    КонецЕсли;
    
    Фото = Адрес;
    
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    Если ЭтоАдресВременногоХранилища(Фото) Тогда
        ТекущийОбъект.Логотип = Новый ХранилищеЗначения( ПолучитьИзВременногоХранилища(Фото) );
    КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Фото = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Логотип");
КонецПроцедуры
   Antoha18rus
 
1 - 26.02.20 - 11:38
ФайлКартинка = Новый COMОбъект("WIA.ImageFile");
ФайлКартинка.LoadFile(ПолеИмениФайла);

Сообщить("Расширение файла: " + ФайлКартинка.FileExtension);
Сообщить("Высота: " + ФайлКартинка.Height);
Сообщить("Ширина: " + ФайлКартинка.Width);
Сообщить("Размер: " + Окр(ФайлКартинка.FileData.Count / 1024, 2) + " Кб");
   GROOVY
 
2 - 26.02.20 - 12:07
(0) Этот код перестанет работать на 16 платформе и выше.
   GROOVY
 
3 - 26.02.20 - 12:09
(1) СОМ объекты то кто юзает сейчас? 2020 год на дворе. Мобильные приложения... КГ/АМ.
   GROOVY
 
4 - 26.02.20 - 12:10
Картинка (Picture)
Свойства:
Вид (Type)
НаборВариантов (VariantSet)
Методы:
Высота (Height)
ГлубинаЦвета (ColorDepth)
Записать (Write)
ОттенкиСерого (GrayScale)
ПлотностьПоВертикали (VerticalDensity)
ПлотностьПоГоризонтали (HorizontalDensity)
ПолучитьДвоичныеДанные (GetBinaryData)
РазмерФайла (FileSize)
ФильтрИменФайлов (FileNameFilter)
Формат (Format)
Ширина (Width)
Конструкторы:
Конструктор по умолчанию
На основании файла
Формирование из двоичных данных
Описание:
Представляет собой картинку из коллекции картинок, пустую картинку, либо картинку, загруженную из внешнего файла, или ссылку на стандартную картинку.
Внимание! Не поддерживаются картинки указанных форматов:
картинки формата ICO, содержащие изображения в формате PNG,
картинки формата BMP, использующие тип сжатия данных JPEG и PNG.
Если картинка создана с вариантами, то методы получения свойств возвращают информацию для текущего варианта.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер), мобильный автономный сервер.
Возможен обмен с сервером. Сериализуется. Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту, определяется в пространстве имен {http://v8.1c.ru/8.1/data/ui}. Имя типа XDTO: Picture.
Использование в версии:
Доступен, начиная с версии 8.0.
   rphosts
 
5 - 26.02.20 - 12:25
(2) ммм, что-то в асинхронных вызовах будет изменено?
   GROOVY
 
6 - 26.02.20 - 12:51
(5) Ну да. Теперь есть НачатьПомещениеФайлаНаСервер().
   13_Mult
 
7 - 26.02.20 - 13:16
(5) Не так давно пришлось определять версию платформы и использовать разные методы. И у некоторых одинаковых функций параметры и их количество изменяются. ))

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.