Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подключение внешней компоненты V8ADD

Подключение внешней компоненты V8ADD
Я
   Arkanit
 
25.02.20 - 16:13
Доброго времени суток!
На строке "Объект = Новый ("Addin.Clipboard");" говорит что не знает такого типа объекта.
Подскажите, в чем может быть проблема.

&НаКлиенте
Процедура ПолучитьИзБуфераОбмена(Команда)
    АдресВоВременномХранилище = ПоместитьВнОбработкуВоВременноеХранилище();
    Данные = ПолучитьИзВременногоХранилища(АдресВоВременномХранилище);
    ПутьКФайлу = КаталогВременныхФайлов() + "Clipboard.dll";
    Данные.Записать(ПутьКФайлу);
    
    Если ПодключитьВнешнююКомпоненту(ПутьКФайлу,"Clipboard",ТипВнешнейКомпоненты.COM) Тогда
        Объект = Новый ("Addin.Clipboard");
    КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ПоместитьВнОбработкуВоВременноеХранилище()
    Макет = ПолучитьОбщийМакет("V8ADD");
    
    Возврат ПоместитьВоВременноеХранилище(Макет);
КонецФункции
   _Дайвер_
 
1 - 25.02.20 - 16:14
(0) Компонента зарегистрирована?
   mikecool
 
2 - 25.02.20 - 16:19
объекто точно "Addin.Clipboard"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.