Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не могу ничего написать в поле HTML документа в платформе 8.3.16, ранее работало

Не могу ничего написать в поле HTML документа в платформе 8.3.16, ранее работало
Я
   Повелитель
 
24.02.20 - 08:43
У нас в конфигурации реализован обмен сообщениями между пользователями.
Всё работало много лет.
Поставил платформу 8.3.16 перестало работать.
Почитал, пишут что изменился движок браузера в платформе.
Но как решить проблему не знаю.
Помогите.

Вот так в платформе 8.3.9 выглядит
https://yadi.sk/i/bISFxc1vvgS_Ag

А вот так в 8.3.16
https://yadi.sk/i/UilZJ_ag5s8Wow


Вот весь коды из формы:


/////////////////////////////////////////////////////////////

Перем Документ;

Процедура ПолеHTMLДокумента1onclick(Элемент, pEvtObj)
    
    Попытка
        ПолноеИмя = pEvtObj.srcElement.nameProp;
    Исключение
        Возврат;
    КонецПопытки;
    
    Документ.execCommand("InsertImage", Ложь, pEvtObj.srcElement.href);
    
    Документ.Body.ContentEditable = "false";
    Документ.Body.ContentEditable = "true";
    
    
    ЭтаФорма.ТекущийЭлемент = ЭлементыФормы.ТекстСообщенияHTML;
    
        
КонецПроцедуры

Процедура ПриОткрытии()
    Документ = ЭлементыФормы.ТекстСообщенияHTML.Документ;
КонецПроцедуры

Процедура ТекстСообщенияHTMLДокументСформирован(Элемент)
    Документ.Body.ContentEditable = "true";
КонецПроцедуры

/////////////////////////////////////////////////////////////


Тестовая обработка Тест.epf там всего 1 форма и 3 процедуры.
https://yadi.sk/d/CHcu2r74RXVjig
   Повелитель
 
1 - 24.02.20 - 13:24
(0) Помогите пожалуйста.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.