Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КД2 исключить из обмена выборочные документы

КД2 исключить из обмена выборочные документы
Я
   Sayan_mi
 
21.02.20 - 10:00
Требуется выгружать документы выборочно, пользователь указывает в ручную.
В объекте обработки построенной на основании стандартного универсального обмена добавил реквизит ТЧ СписокРеализаций, заполнил его подобранными пользователями документами.
В КД в правилах выгрузки данных перед выгрузкой написал такой текст:
СписокДокументов = СписокРеализаций.Выгрузить();
НеНайденаСтрока = Истина;
Для Каждого ткСтрока ИЗ СписокДокументов Цикл
    Если ткСтрока.Реализация = Объект.Ссылка Тогда
        НеНайденаСтрока = Ложь;
        Прервать;
    КонецЕсли;    
КонецЦикла;    

Если НеНайденаСтрока Тогда
    Отказ = Истина;
КонецЕсли;
В данном случае Список реализаций пуст, но документы всё равно выгружаются.
Пробовал не через ТЗ а через список значений и НайтиПоЗначению(). Всё равно не отрабатывает.
Что я делаю не так?
   mikecool
 
1 - 21.02.20 - 10:20
стандартная выборка, пользователь в универсальной выгрузке сам настраивает отбор
   Sayan_mi
 
2 - 21.02.20 - 10:41
(1) Знаю. Но попросили ограничить выбор объектов в плане и сделать более удобный выбор. Заполнение отбора в КомпоновщикеНастроек тоже ничего не даёт :-(
   azt-yur
 
3 - 21.02.20 - 10:52
(0) это весь код из обработчика? Судя по коду Отказ должен устанавливаться.
Выборка Стандартная стоит? Нигде больше в правилах ВыгрузитьПоПравилу не встречается? в этом случае ПВД не отрабатывает
Можешь еще для верность этот код в обработчик ПКО засунуть
   Sayan_mi
 
4 - 21.02.20 - 11:50
(3) Выборка стояла стандартная, когда перенёс код  в обработчики событий перед выгрузкой - заработало.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.