Вход | Регистрация
 

КД РКО=>РКО Статья движения ден. средств

КД РКО=>РКО Статья движения ден. средств
Я
   Gray776
 
20.02.20 - 16:01
В общем никак не пойму как заполнить после загрузки статьи ДДС в базе приемнике. Там почему-то 2 места где их указать надо.

        Объект.СтатьяДвиженияДенежныхСредств = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду("100000011");
Заполняет в одном месте как заполнить вторую?
   vicof
 
1 - 20.02.20 - 16:03
ВтороеМесто.СтатьяДвиженияДенежныхСредств = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду("100000011");
   Gray776
 
2 - 20.02.20 - 16:13
(1) База Приемник БП 2,0. Когда Операция "Инкассация" то на вкладке 2 поля для ввода Статьи ДДС. Они должны различаться в этом случае. А Так как я написал в (0) заполняется только одно поле второе пустое остается.
   mikecool
 
3 - 20.02.20 - 16:16
(2) ты не читатель?
   vicof
 
4 - 20.02.20 - 16:17
Вроде стаж 12 лет. Надо зайти в форму, посмотреть, откуда тянутся данные в поле ввода второй статьи. И заполнить эти данные в источнике данных.
   d4rkmesa
 
5 - 20.02.20 - 16:19
(0) В Бухгалтерии есть полезная функция в менеджерах документов, Документы[ИмяДокумента].ЕстьРасшифровкаПлатежа(...)
   d4rkmesa
 
6 - 20.02.20 - 16:20
(5) Если есть Расшифровка платежа, заполняется ДДС в ТЧ РасшифровкаПлатежа, нет  - Объект.СтатьяДвиженияДенежныхСредств = ...
   Gray776
 
7 - 20.02.20 - 16:22
(6) ТЧ РасшифровкаПлатежа это работа с колекцией получится?
   d4rkmesa
 
8 - 20.02.20 - 16:23
(7) Ну да. Хотя, именно в этом случае, кажется, это не расшифровка платежа. В общем, у меня в одних правилах сделано так в конце обработчика ПослеЗагрузки:

Если (Объект.ВидОперации = Перечисления.ВидыОперацийРКО.Инкассация) ИЛИ
    (Объект.ВидОперации = Перечисления.ВидыОперацийРКО.ПрочийРасход) ИЛИ
    (Объект.ВидОперации = Перечисления.ВидыОперацийРКО.ВыдачаПодотчетномуЛицу) ИЛИ
    (Объект.ВидОперации = Перечисления.ВидыОперацийРКО.ВзносНаличнымиВБанк) Тогда
    СчетДебетаОперации = Объект.СчетУчетаРасчетовСКонтрагентом;
    Если ЗначениеЗаполнено(СчетДебетаОперации) Тогда
        КоличествоСубконто = СчетДебетаОперации.ВидыСубконто.Количество();
        Для НомерСубконто = 1 По КоличествоСубконто Цикл
            Если СчетДебетаОперации.ВидыСубконто[НомерСубконто - 1].ВидСубконто = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиДвиженияДенежныхСредств Тогда
                Объект["СубконтоДт" + НомерСубконто] = Объект.СтатьяДвиженияДенежныхСредств;
            КонецЕсли;            
        КонецЦикла;
        Если (Объект.ВидОперации = Перечисления.ВидыОперацийРКО.ПрочийРасход) И
            (СчетДебетаОперации = ПланыСчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда) Тогда
            Для НомерСубконто = 1 По КоличествоСубконто Цикл
                Если СчетДебетаОперации.ВидыСубконто[НомерСубконто - 1].ВидСубконто = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РаботникиОрганизаций Тогда
                    Объект["СубконтоДт" + НомерСубконто] = Объект.Контрагент;
                КонецЕсли;            
            КонецЦикла;            
        КонецЕсли;        
    КонецЕсли;
КонецЕсли;
   Gray776
 
9 - 21.02.20 - 11:35
(8) Блин точно там в конфигураторе три субконто же.. Во блин я тупанул то то в расшифровке не находил ДДС

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.