Вход | Регистрация
 

Что за мистика - функция возращает одно значение, а присваивания нет

Что за мистика - функция возращает одно значение, а присваивания нет
Я
   RomaH
 
18.02.20 - 09:44
Объект.ФайлПротокола = ЗаписатьФайлВСправочник(АдресФайла,ПараметрыФайла);
    
    Модифицированность = Истина;
    
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЗаписатьФайлВСправочник(Знач АдресФайла,Знач ПараметрыФайла)
    
    Если Не ЗначениеЗаполнено(ПараметрыФайла.ВладелецФайлов.ФайлПротокола) Тогда
        Результат = РаботаСФайлами.ДобавитьФайл(ПараметрыФайла,АдресФайла);
    Иначе
        //     <обязательные>
        //     * АдресФайлаВоВременномХранилище - Строка - Адрес новых двоичных данных файла.
        //     * АдресВременногоХранилищаТекста - Строка - Адрес новых двоичных данных текста,
        //РаботаСФайлами.ОбновитьФайл(ПараметрыФайла.ВладелецФайлов.ФайлПротокола,Новый Структура("АдресФайлаВоВременномХранилище",АдресФайла));
        РаботаСФайлами.ОбновитьФайл(ПараметрыФайла.ВладелецФайлов.ФайлПротокола,ПараметрыФайла);
        Результат = ПараметрыФайла.ВладелецФайлов.ФайлПротокола;
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции


Результат - Файл 1
А
Объект.ФайлПротокола = Файл 2

То что возвращает функция
https://dl.dropboxusercontent.com/s/8jfojpujojb6yn1/2020-02-18_09h43_26.png?dl=0

То что вижу на клиенте:
https://dl.dropboxusercontent.com/s/aqr9q4yxr1vfq13/2020-02-18_09h43_36.png?dl=0
   RomaH
 
1 - 18.02.20 - 09:46
   hhhh
 
2 - 18.02.20 - 10:01
(1) типы разные у объект.файлпротокола и результат
   Franchiser
 
3 - 18.02.20 - 10:01
Может быть есть одноименный реквизит формы ФайлПротокола с неправильным типом?
   RomaH
 
4 - 18.02.20 - 10:10
все нормально с типами и именами

еще прикол 
создаю док (владелец) записываю
начинаю выполнять процедуру (сначала добаляет файл новый, потом его обновляет) - все ок отрабатывает (отображение меняет)

потом записываю док
и все - отображение остается неизменным пока ... открыть файл не сделаю (серверный вызов?)

открыть закрыть док не помогает (но отображение меняется на правильное) - поведение остается прежним
   RomaH
 
5 - 18.02.20 - 10:19
при вызове открыть файл

https://dl.dropboxusercontent.com/s/k8nd4lgx5td9eq6/2020-02-18_10h17_47.png?dl=0

после открытия в форме наблюдаю "правильное" представление ссылки
   RomaH
 
6 - 18.02.20 - 10:27
ОповеститьОбИзменении(ФайлПротокола1);
помогло

казалось бы - при чем тут динамические списки?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.