Вход | Регистрация
 

Выход из режима редактирования при изменении заголовка колонки

Выход из режима редактирования при изменении заголовка колонки
Я
   igwtbox
 
17.02.20 - 12:40
Если в процессе редактирование таблицы формы изменить заголовок одной из колонок, то происходит непроизвольный выход из режима редактирования. Например, задача такая: при выборе счета в табличной части проверяется, что все счета во всей ТЧ одинаковые, и если одинаковые - осмысленно назвать колонки с субконто.
Может, я чего не понимаю, и существует "правильный" способ переименования колонки? Или единственный вариант это после переименования вызвать Элементы.Таблица.ИзменитьСтроку() ? Мне такой вариант не нравится тем, что после этого не будет работать стандартная отмена редактирования, например по кнопке Esc.
 
 
   Ёпрст
 
1 - 17.02.20 - 13:30
(0) Отдать событию через оповещение, которое поменяет тебе имена колонок
   igwtbox
 
2 - 17.02.20 - 13:34
(1) НЕ понимаю. Было бы здорово объяснить чуть нагляднее.
   Ёпрст
 
3 - 17.02.20 - 15:40
(2) свой код изменения названия колонки покажите, сперва
   igwtbox
 
4 - 17.02.20 - 18:14
(3)
&НаКлиенте
Процедура ТабличнаяЧасть1Реквизит1ПриИзменении(Элемент)
    Элементы.ТабличнаяЧасть1Реквизит2.Заголовок = "Тест";
КонецПроцедуры
   Ёпрст
 
5 - 17.02.20 - 23:40
(4)
или так:
&НаКлиенте
Процедура ТабличнаяЧасть1Реквизит1ПриИзменении(Элемент)
    Элемент.Заголовок = "Вася " + Формат(ТекущаяДата(),"ДФ=HH:mm:ss");
    ПодключитьОбработчикОжидания("СменитьЗаголовок", 0.1, Истина);
КонецПроцедуры

&НаКлиенте
Процедура СменитьЗаголовок()
    Элементы.ТабличнаяЧасть1.ИзменитьСтроку();
КонецПроцедуры


Или так:

Процедура ТабличнаяЧасть1Реквизит1ПриИзменении(Элемент)
    Элемент.Заголовок = "Вася " + Формат(ТекущаяДата(),"ДФ=HH:mm:ss");
    Оповестить("Вася")// в свойствах формы задать обработчик "Обработка оповещения"

КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия="Вася" Тогда
          СменитьЗаголовок();
        КонецЕсли;
КонецЕсли;
&НаКлиенте
Процедура СменитьЗаголовок()
    Элементы.ТабличнаяЧасть1.ИзменитьСтроку();
КонецПроцедуры


   igwtbox
 
6 - 18.02.20 - 12:31
(5) Не понимаю.
Но редактирование-то в этом случае прекращается. А я спросил, есть ли тайное знание, как не прерывать редактирование.
   Ёпрст
 
7 - 18.02.20 - 22:03
(6) редактирование не прекращается в обоих случаях, я ж проверил
   Ёпрст
 
8 - 18.02.20 - 22:04
оно "заново" входит, через ИзменитьСтроку()

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.