Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Загрузить excel файл в табличный документ с сохранением форматирования.

Загрузить excel файл в табличный документ с сохранением форматирования.
Я
   JuixyJes
 
14.02.20 - 11:49
Добрый день! Загружаю в ТД excel файл, но форматирование ячеек не сохраняется. не знаю что делать.


&НаСервере
Процедура ЗагрузитьФайлНаСервере(Путь)
    Объект.Лист.Прочитать(Путь,СпособЧтенияЗначенийТабличногоДокумента.Значение);
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьФайл(Команда)
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл загрузки";
    Диалог.ПолноеИмяФайла = "";
    Диалог.ПредварительныйПросмотр = Истина;
    Диалог.Фильтр =
    "Файл excel (*.xls;"; // картинки
    
    Если Диалог.Выбрать() Тогда
        ОтчетОбИспользованииСредствМБ = Диалог.ПолноеИмяФайла;
    Иначе
        Возврат;
    КонецЕсли;
    
    ЗагрузитьФайлНаСервере(ОтчетОбИспользованииСредствМБ);
КонецПроцедуры
   JuixyJes
 
1 - 14.02.20 - 11:49
Грузила так
   dka80
 
2 - 14.02.20 - 11:53
Попробуй убрать СпособЧтенияЗначенийТабличногоДокумента.Значение
и Лист - это же табличный документ?
Замечание не по вопросу: в клиент-серверном варианте вообще не будет этот код работать.
   JuixyJes
 
3 - 14.02.20 - 12:01
(2) код работает. причем не всегда все правильно.
   JuixyJes
 
4 - 14.02.20 - 12:03
вплане того. что один тип документов со всем форматированием копирует, второй без форматирования

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.