Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не записывать определенные записи набора регистра сведений

Не записывать определенные записи набора регистра сведений
Я
   Slon747
 
13.02.20 - 15:29
Зависимый регистр сведений.
Можно ли при его записи не определенные записывать наборы записей?
Можно при проведении их отсекать и не передавать на запись.
Но хотелось бы сразу в модуле набора записей отсекать.

Процедура ПередЗаписью(Отказ, Для каждого Запись Из ЭтотОбъект Цикл
       Если Эта_запись_не_нужна Тогда
       //не записывать этот набор
       КонецЕсли;
КонецЦикла;
 
 
   Slon747
 
1 - 13.02.20 - 15:31
(0) случайно отправил.
Вот как-то так можно?
Процедура ПередЗаписью(Отказ, Замещение)
    
    Для каждого Запись Из ЭтотОбъект Цикл
        Если Эта_запись_не_нужна Тогда
            //не записывать этот набор    

        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры
   Жан Пердежон
 
2 - 13.02.20 - 15:34
Можно но не так. При проведении ты сам набор записей готовишь: нужные добавляй в набор, ненужные удаляй
   Slon747
 
3 - 13.02.20 - 15:35
(2) Как я сказал, хотелось-бы не зависеть от логики проведения
   lodger
 
4 - 13.02.20 - 15:36
(1) это дикий копрокод, но из набора в ЭтотОбъект можно убрать строки.
или выгрузить в тз, поковырять и загрузить обратно.
что суть одно и то же, но во втором случае будет больше расход мощностей и больше возможностей для алгоритмов.
   lodger
 
5 - 13.02.20 - 15:37
Процедура ПередЗаписью(Отказ, Замещение)
УдалитьМасс =    новый массив;
    Для каждого Запись Из ЭтотОбъект Цикл
        Если Эта_запись_не_нужна Тогда
            УдалитьМасс.добавить(Запись);
        КонецЕсли;
    КонецЦикла;
    
 Для каждого Запись Из УдалитьМасс Цикл
        
            ЭтотОбъект.Удалить(Запись);
        
    КонецЦикла;
КонецПроцедуры
   spiller26
 
6 - 13.02.20 - 15:37
   Slon747
 
7 - 13.02.20 - 15:41
(5)(6) Спасибо, подумаю.
Есть еще вариант. Записывать в ресурсы нули ))
Поправка к (0) - Регистр не сведений, а накоплений.
   vicof
 
8 - 13.02.20 - 15:42
(0) А почему бы не пересмотреть логику приложения, а не говнокодить?
   Slon747
 
9 - 13.02.20 - 15:43
(8) Бывает, это того не стоит. За все приходится платить. Если не деньгами, то временем.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.