Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Процедура или функция с указанным именем не определена (ПоказатьВопрос1)

Процедура или функция с указанным именем не определена (ПоказатьВопрос1)
Я
   Эльчин
 
13.02.20 - 15:22
&НаКлиенте
Функция ПоказатьВопрос1(НаимКонт)
    Режим = РежимДиалогаВопрос.ДаНет;
    Ответ = Вопрос("!: " + НаимКонт + " adlı müştərinin borcu məbləğdən daha azdır", Режим, 0);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
        Возврат Ложь;
    КонецЕсли;    
КонецФункции

// Процедура обработчик события ПередЗаписьюНаСервере.
//
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    Если ПараметрыЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда
        
        ТекстСообщения = "";
        ПроверитьСоответствиеДоговораУсловиямДокумента(Объект.РасшифровкаПлатежа, ТекстСообщения, Объект.Ссылка, Объект.Организация, Объект.Контрагент, Объект.ВидОперации, Отказ);
        
        Если ТекстСообщения <> "" Тогда
            
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = ?(Отказ, НСтр("az='Sənəd keçirilməmişdir!';ru='Документ не проведен! '") + ТекстСообщения, ТекстСообщения);
            Сообщение.Сообщить();
            
            Если Отказ Тогда
                Возврат;
            КонецЕсли;
            
        КонецЕсли;
        
        //++
        Для Каждого стр Из Объект.РасшифровкаПлатежа Цикл
            Запрос = Новый Запрос;
            Запрос.Тек.....
......
.....
Параметр("Контрагент", Объект.Контрагент);
            Запрос.УстановитьПараметр("Период", КонецДня(Объект.Дата));
            
            РезультатЗапроса = Запрос.Выполнить();
            
            ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
            
            Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                долг = ВыборкаДетальныеЗаписи.СуммаВалОстаток- Объект.СуммаДокумента + 1;
                Если Долг < 0 Тогда
                    Если Не ПоказатьВопрос1(Объект.Контрагент.Наименование) Тогда

здравствуйте. в этом строке выводиться ощибкак "Процедура или функция с указанным именем не определена (ПоказатьВопрос1)". почему?
 
 
   ДенисЧ
 
1 - 13.02.20 - 15:24
С сервера клиентскую процедуру вызывать? Ты силён...
   spiller26
 
2 - 13.02.20 - 15:31
(0) Проверку перенеси на клиент, ты пытаешься на сервере кинуть вопрос клиенту.
   Эльчин
 
3 - 14.02.20 - 09:18
(1)  спасибо. не знал что нельзя)). а не знаю как сделать в этом случае. потому что проверка ведется на сервере, а функция ВОПРОС клиентская. как делать в таком случае?
   ДенисЧ
 
4 - 14.02.20 - 09:19
(3) Делай все проверки на клиенте, потом уходи на сервер
   Kigo_Kigo
 
5 - 14.02.20 - 09:21
(4) ИЛИ
&НаКлиенте
Функция ЗадатьВпрос(ПараметрыВопроса)

&НаСервере
Процедура Проверка()

Если ЗадатьВпрос(ПараметрыВопроса) тогда
   Kigo_Kigo
 
6 - 14.02.20 - 09:22
А не внимательно посмотрел пост, странно что не сработало
   Михаил Михайлович
 
7 - 14.02.20 - 09:23
(6) что не сработало?
   Kigo_Kigo
 
8 - 14.02.20 - 09:42
(7) Переход на клиента для вопроса
   Эльчин
 
9 - 14.02.20 - 09:44
спасибо всем. проблема решено

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.