Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работа с XDTO

Работа с XDTO
Я
   Sej
 
12.02.20 - 12:00
При получении ответа от веб-сервиса получаю объект XDTO, который содержит в себе списокXDTO. Сохраняю объектXDTO в текстXML. После пытаюсь текстXML преобразовать обратно в объектXDTO. Некоторые свойства, которые первоначально были спискомXDTO , становятся объектом. В чем может быть ошибка?
   ДенисЧ
 
1 - 12.02.20 - 12:27
хдто без схемы одиночные объекты, которые раньше были списками длины 1, делает объектами.
   RomaH
 
2 - 12.02.20 - 12:34
//Для Каждого ОбъектXDTO Из ПолучитьДаннынеСпискаXDTO(МойСписокXDTO) Цикл

//    \\обработка данных
//КонецЦикла


Функция ПолучитьДаннынеСпискаXDTO(Знач ОбъектXDTO) Экспорт

    Если ТипЗнч(ОбъектXDTO) = Тип("ОбъектXDTO") Тогда
        Результат = Новый Массив;
        Результат.Добавить(ОбъектXDTO);
    Иначе
        Результат = ОбъектXDTO;
    КонецЕсли;

    Возврат Результат;

КонецФункции
   palsergeich
 
3 - 12.02.20 - 13:04
(1) На сколько я помню и со схемой тоже, помню горело у меня от этого
   palsergeich
 
4 - 12.02.20 - 13:05
(2) Дадада.
   Sej
 
5 - 12.02.20 - 13:48
При прямом указании типа xdto выходит ошибка Недопустимое состояние объекта
[xdto - d:\jenkins\ci_builder2\windowsbuild2\platform\src\xdto\src\xdtostreamimpl.cpp (962)]

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.