Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11.4 Расширение - убрать возможность удаления документа

УТ 11.4 Расширение - убрать возможность удаления документа
Я
   Misty
 
12.02.20 - 09:27
Добрый день. Конфигурация УТ 11.4.9.82 . Платформа 8.3.16. Поставили задачу - чтобы кассиры не могли изменять проведенные документы, а так же снимать пометку проведения и пометку удаления. Создал реализацию, распечатал чеки и все, если что то вдруг надо поправить, то только помечаешь на удаление и создаешь новый документ. Добавила расширение- в нем создала справочник пользователей, которым нельзя изменять проведенные документы. В форме документа перед записью создала обработчик:

&НаСервере
Процедура Расш1_ПередЗаписьюПередНаСервере(Отказ)
    НайденП = Справочники.Расш1_ПользователиЗапретПроведения.НайтиПоРеквизиту("пользователь", Пользователи.ТекущийПользователь());
    Если НайденП <> Справочники.Расш1_ПользователиЗапретПроведения.ПустаяСсылка() тогда
        Если Объект.Проведен  тогда
            сообщить("проводить нельзя");
            отказ=Истина;
        КонецЕсли;
    Конецесли;
КонецПроцедуры

&НаКлиенте
Процедура Расш1_ПередЗаписьюПеред(Отказ, ПараметрыЗаписи)
    Расш1_ПередЗаписьюПередНаСервере(Отказ);
КонецПроцедуры

Таким образом почти все пожелания удовлетворены - нет возможности изменять проведенные, нет возможности отменять проведение. И можно удалить. Но не пойму как реализовать запрет на отмену удаления? Буду признательна за идеи. Спасибо
   Chameleon1980
 
1 - 12.02.20 - 09:28
подписка с анализом режима записи
   Misty
 
2 - 12.02.20 - 09:37
(1) Тогда придется конфигурацию снимать с поддержки, этого хочется как раз избежать.
   Misty
 
3 - 12.02.20 - 09:38
или подписку на событие добавить расширение?
   yzimin
 
4 - 12.02.20 - 09:45
(3) можно просто переопределить в расширении процедуры из модуля РеализацияТоваровУслугЛокализация
   palsergeich
 
5 - 12.02.20 - 09:47
а теперь открой список и сделай то же самое чеерез контекстное меню.
Внезапно это отработает и весь этот уникальный код на помойку.
тебе нужны события При и Перед записью модуля объекта, они расширяются
   Misty
 
6 - 12.02.20 - 09:47
(4) что такое РеализацияТоваровУслугЛокализация?
   yzimin
 
7 - 12.02.20 - 09:48
(6) общий модуль
   Misty
 
8 - 12.02.20 - 09:51
(5) как расширить модуль объекта? Если я в расширении добавляю какую то процедуру в модуль объекта, то она не работает
   yzimin
 
9 - 12.02.20 - 09:52
(8) Расширь просто модуль реализации
   Misty
 
10 - 12.02.20 - 09:57
(9) так я расширила модуль формы документа. В нем и написала эти две процедуры. Ничего не понимаю...
   oslokot
 
11 - 12.02.20 - 10:15
(10) говорят же, расширь модуль а не модуль формы
   Chameleon1980
 
12 - 12.02.20 - 10:22
(12) в модуле не только интерактивное срабатывание
   pechkin
 
13 - 12.02.20 - 10:34
откуда права на удаление? или про програмно речь?
   Misty
 
14 - 13.02.20 - 03:50
С расширениями столкнулась только 2 дня назад. Про такой механизм и не знала.
Не было понятно, что значит расширь модуль объекта, т.к. в исходной конфигурации нет команды "добавить модуль в расширение". Оказалось, что в расширении можно просто открыть модуль и там писать таким образом:
&Перед("ПередЗаписью")
Процедура ПередЗаписьюМоя(Отказ, РежимЗаписи, РежимПроведения)
Теперь все срабатывает как надо.
Вот это я и хотела услышать в поддержке. 2 дня мучений и все получилось.
Всем спасибо.
   Chameleon1980
 
15 - 13.02.20 - 04:50
и не забывай про отличия переззаписью из формы и в модуле
   Misty
 
16 - 13.02.20 - 05:49
(15) есть существенные отличия? а можно поподробнее
   Chameleon1980
 
17 - 13.02.20 - 08:02
(16) а сама как думаешь
когда происходит вообще инициализация ПриЗаписи там и там?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.