Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Установить текущую строку при открытии новой формы

Установить текущую строку при открытии новой формы
Я
   SprayTM
 
12.02.20 - 08:37
8.3 Обычные формы

На форме есть ТЧ, при начале выбора в колонке открывается новая форма. При ее открытии, если заполнена ячейка, необходимо найти эту строку и сделать ее текущей. Как вообще это можно правильно реализовать?

Процедура ТаблицаСопоставленияНоменклатураКонтрагентаНачалоВыбора(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    ФормаПодбора = ПолучитьФорму("ФормаПодбора");
    ВыбранноеЗначение = ФормаПодбора.ОткрытьМодально();
    
    Если ВыбранноеЗначение <> Неопределено Тогда
        ТекущаяСтрока = Элементыформы.ТаблицаСопоставления.ТекущаяСтрока;
        Если ТекущаяСтрока <> Неопределено Тогда
            
            ЗаполнитьЗначенияСвойств(ТекущаяСтрока, ВыбранноеЗначение);                    
            ДобавитьЗаписьВРегистрСведенийПоСопоставлению(ТекущаяСтрока);
                        
        КонецЕсли;
    КонецЕсли;    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.