Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Странная раскраска календаря

Странная раскраска календаря
Я
   IgorRet
 
09.02.20 - 17:01
Подскажите, что в этом коде не так ?
Процедура Реквизит1ПриВыводеПериода(Элемент, ОформлениеПериода)
    Для каждого ТекущийДень из ОформлениеПериода.Даты Цикл
        
        Если ТекущийДень.Дата = Дата ("07.02.2020 00:00:00") Тогда
            ТекущийДень.ЦветТекста = Новый Цвет (255, 0, 0);
        КонецЕсли;
        
        //ЭтотДень = ЗапросСвойстваДаты (ТекущийДень.Дата);
        //Если ЭтотДень Тогда
        //    ТекущийДень.ЦветТекста = Новый Цвет (255, 0, 0);
        //КонецЕсли;
            
    КонецЦикла;

КонецПроцедуры

После выполнения процедуры седьмое февраля окрашивается в красный цвет, а все остальные дня месяца в черный. При этом также меняется и шрифт цифр. Оформление других месяцев остается без изменений
   ДенисЧ
 
1 - 09.02.20 - 17:31
Странно было бы, если бы 7е не окрашивалось бы...
   Rapelsina
 
2 - 09.02.20 - 17:38
конечная ваша цель какая?
   IgorRet
 
3 - 09.02.20 - 18:09
В конкретном примере красным цветом должно окрасится седьмое февраля, остальные числа остаться без изменений. Т.е. выходные дни красные, рабочие черные. Но черными становятся все дни, кроме седьмого числа. И почему меняется шрифт всех чисел февраля ?
   ДенисЧ
 
4 - 09.02.20 - 18:11
(3) Потому что ты закомментировал всю остальную раскраску
   IgorRet
 
5 - 09.02.20 - 18:15
Я закомментировал основной текст процедуры и написал упрощенный, чтобы легче было понять суть проблемы. Если его раскомментировать, то числа всех месяцев календаря окрасятся в черный цвет, за исключением ЭтотДень = Истина
   ДенисЧ
 
6 - 09.02.20 - 18:18
Если все числа чернятся - значит, ЗапросСвойстваДаты  возвращает ложь. Наверное, производственный календурь (или откуда оно там берёт данные) не заполнен.
   IgorRet
 
7 - 09.02.20 - 18:28
Календарь это реквизит в форме документа в формате Дата и с видом поле календаря. Если процедуру ПриВыводеПериода не писать, то выводится стандартный календарь с красными числами выходных дней. Праздничные дни этот календарь не знает. Вот их я и пытаюсь добавить. По идее, должен меняться цвет только тех чисел, которые удовлетворяют условию Если. Остальные должны оставаться в первоначальном виде. Про изменение шрифта вообще речь не идет.
Есть знающие люди ?
   ДенисЧ
 
8 - 09.02.20 - 18:43
Ещё раз. Праздники берутся из производственного календаря. Вот тебе туда и нужно смотреть для раскраски.
Так же там, кстати, и переносы находятся. Поскольку не все субботы в этом году - выходные.

Сам календарь - берётся из типовых конфигураций. Там же смотрится и принцип его раскраски. Не надо изобретать левосипедов.
   IgorRet
 
9 - 09.02.20 - 19:05
Ёлочки зеленые... Какой производственный календарь ? Нет его, это не типовая конфигурация. Я пишу свой календарь. И до сегодняшнего дня все у меня раскрашивалось правильно. А сегодня вот такой нежданчик. Не знаешь - не надо комментировать
И кстати, какие субботы в этом году не являются выходными днями ?
   ДенисЧ
 
10 - 09.02.20 - 19:32
(9) Я тебе говорю, как по уму делать надо... А ты ерепенишься. А то и хорохоришься... Не хочешь - не слушай.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.