Вход | Регистрация
 

вызвать форму справочника из ТЧ документа

вызвать форму справочника из ТЧ документа
Я
   bb
 
06.02.20 - 10:49
При вводе нового элемента в табличной части документа (с помощью пиктограммы на панели инструментов, либо нажав клавишу Ins) появляется новая строка.
В первой колонке моей табличной части есть реквизит имеющий Тип "СправочникСсылка.МоёИмяСправочника". При вводе новой строки в табличной части создается пустая строка и курсор позиционируется на первой колонке новой строки. Идет синяя подсветка поля и кнопка (в виде 3-х точек) для открытия и выбора соответствующего моего элемента справочника.
Вопрос: как можно сразу открыть формы выбора элемента справочника при вводе новой строки в табличную часть документа?
(Т.е. к какому событию Табличной части привязаться и что в нем написать?)
   DTX 4th
 
1 - 06.02.20 - 10:50
ПриНачалеРедактирования
   bb
 
2 - 06.02.20 - 10:54
(1) Форма Открывается но активным остается форма документа, а форма справочника уходит на второй план
   DTX 4th
 
3 - 06.02.20 - 10:55
СтандартнаяОбработка
   bb
 
4 - 06.02.20 - 10:58
(Элемент, НоваяСтрока, Копирование)
только это (3)
   DTX 4th
 
5 - 06.02.20 - 10:59
Формы то какие? Обычная/управляемые?
Всегда есть запасной вариант - сделать свою кнопку добавления)
   bb
 
6 - 06.02.20 - 11:00
(5) Обычная
   bb
 
7 - 06.02.20 - 11:04
(5) согласен с этим,но нужно на ins чтоб срабатывало действие
   DTX 4th
 
8 - 06.02.20 - 11:06
Перем Ф;

Процедура ТабличнаяЧасть1ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Ф = Справочники.Номенклатура.ПолучитьФормуВыбора();
    Ф.ВладелецФормы = ЭтаФорма;
    Ф.Открыть();
КонецПроцедуры

Процедура ОбновлениеОтображения()
    Если Ф <> Неопределено Тогда    
        Ф.Активизировать();        
    КонецЕсли; 
КонецПроцедуры


   bb
 
9 - 06.02.20 - 11:07
у меня конфигурация не типовая,
хотя есть и типовая вот там при нажатии ins срабатывает открытие справочника
   Василий Алибабаевич
 
10 - 06.02.20 - 11:08
(9) Нужно взять правильный инструмент. Юзай ПередНачаломДобавления.
   DTX 4th
 
11 - 06.02.20 - 11:21
(10) Кстати, да, больше подходит
Но некоторые вещи можно накостылить только через ОбновлениеОтображения
   bb
 
12 - 06.02.20 - 11:35
(8) Сработало , всем спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.