Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод списка документов.

Вывод списка документов.
Я
   ЗлаяЗая
 
05.02.20 - 11:18
Где и как формируется список документов, который выводится в журнале документов?
Мне нужно добавить в журнал документов новую колонку. Я ее добавила.
При открытии журнала она должна определенным образом заполняться.
В процедуре ПриОткрытии никак не могу понять как организовать цикл по списку. Где этот список взять?
По ЭлементыФормы.Список цикл идти не хочет.
   Михаил Козлов
 
1 - 05.02.20 - 11:21
Напишите какая конфигурация (хотя бы УФ или ОФ).
Если ОФ, то в журнале нужно определить, как заполняется Ваша колонка.
В УФ нужно править запрос динамического списка.
   ЗлаяЗая
 
2 - 05.02.20 - 11:24
(1) ОФ. А где в журнале определить, как заполняется колонка. Это мне и надо.
   Dimeric
 
3 - 05.02.20 - 11:25
Да , список заполняется из запроса в динамическом списке
   ДенисЧ
 
4 - 05.02.20 - 11:26
(2) ПриВыводеСтроки, ПриПолученииДанных
   unenu
 
5 - 05.02.20 - 11:29
ОФ, у нее какая-то некрофильская конфа и полагаю ПриВыводеСтроки успешно завесит сервер, зато в колонке будут картинки
   ЗлаяЗая
 
6 - 05.02.20 - 11:30
(5) конфа УПП
   ДенисЧ
 
7 - 05.02.20 - 11:32
(5) Сервер завешивают обычно УФ. А ОФ - теплые, ламповые и быстрые.
   ЗлаяЗая
 
8 - 05.02.20 - 11:33
Журнал "Реализация товаров и услуг".
В форме добавила колонку.
Заполняться она должна: смотрим, заполнена ли в документе определенная вкладка и ставим галочку, что заполнена.
   palsergeich
 
9 - 05.02.20 - 11:34
(7) да конечно, не раз выгребал привыводестроки, когда список в уф минут по 5 открывался
   ДенисЧ
 
10 - 05.02.20 - 11:35
(9) " когда список в уф минут по 5 открывался"
Откуда ты в ПриВыводеСтроки в УФ нашёл? ))
   ДенисЧ
 
11 - 05.02.20 - 11:36
(8) Открой книжки и почитай про ПриВыводеСтроки(). И выпей галап^Wафобазольчику. Чтобы злой не быть ))
   palsergeich
 
12 - 05.02.20 - 11:38
(10) ок, там есть такая же функция, точнее она в УФ скопирована из ОФ
Могу открыть и сказать как она называется, но думаю ты и так все понял.
Простое а давайте выведем в номенклатуре текущий остаток - на УФ тоже зло
   palsergeich
 
13 - 05.02.20 - 11:38
(12) на ОФ имелось ввиду
   ДенисЧ
 
14 - 05.02.20 - 11:39
(12) А откуда в текущей постановке задачи взял остаток? О_о
   palsergeich
 
15 - 05.02.20 - 11:41
(14) Я к тому что вывести поле в ОФ тоже может иметь крайне негативные последствия и говорить, что в ОФ все быстро - лукавство
   ЗлаяЗая
 
16 - 05.02.20 - 11:43
в процедуре СписокПриПолученииДанных(Элемент, ОформленияСтрок)
вклинилась, заполнена/не заполнена вкладка вижу :)))
Осталось сообщить об этом в форме
   Михаил Козлов
 
17 - 05.02.20 - 12:14
(8) Это не журнал, а список документов.
В форме в СписокПриПолученииДанных:
ДЛЯ каждого оф ИЗ ОформленияСтрок Цикл
   оф.<колонка> = <что-то> (не уверен, посмотрите, что в оф в отладчике
КонецЦикла;
   ЗлаяЗая
 
18 - 05.02.20 - 13:09
На ФормеСписка я свою колонку добавила.
Для каждого оформлениеСтроки из ОформленияСтрок Цикл
    Если оформлениеСтроки.ДанныеСтроки.Ссылка.МояВкладка.количество()>0 Тогда
        оформлениеСтроки.ДанныеСтроки.МОЯКОЛОНКА=Истина;
    КонецЕсли;    
КонецЦикла;

в оформлениеСтроки.ДанныеСтроки нет моей колонки. Если правильно понимаю, то там только реквизиты, которые есть у документа,
т.к. Список имеет тип ДокументСписок.РеализацияТоваровИУслуг?
Можно ли каким-то образом заполнять колонку на форме или нужно добавить реквизит?
   hhhh
 
19 - 05.02.20 - 13:18
(18) оформлениеСтроки.ДанныеСтроки.МОЯКОЛОНКА=Истина; что-то хрень здесь. Почему ДанныеСтроки?
   ЗлаяЗая
 
20 - 05.02.20 - 13:20
(19) хрень :) потому и спрашиваю, как правильно.
   ЗлаяЗая
 
21 - 05.02.20 - 13:21
оформлениеСтроки.ДанныеСтроки.ТутЕстьРазныеКолонки кроме моей
   Михаил Козлов
 
22 - 05.02.20 - 13:29
(21) По памяти, если не ошибаюсь оф.Ячейки.<моя колонка>.<УстановитьТекст или изменить оформление: цвет, шрифт>.
   ЗлаяЗая
 
23 - 05.02.20 - 15:29
Спасибо.
Попробовала из с реквизитом и просто колонку. Получилось. Сделала просто колонку.
оформлениеСтроки.Ячейки.МояВкладка.УстановитьТекст(ИСТИНА);


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.