Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

как дату поделить на количесто дней?

как дату поделить на количесто дней?
Я
   Леприкон
 
05.02.20 - 10:59
ТекДата = Неопределено;

(стр.ДатаПлатежа - ТекДата)/(24*60*60);    

ругается на типы
 
 
   butterbean
 
1 - 05.02.20 - 11:00
зачем вообще отнимать пустое значение от даты? если прям ну очень надо - отнимай пустую дату: Дата(1,1,1)
   Temai
 
2 - 05.02.20 - 11:00
Ну проверь на типы в отладке, там и видно будет. Зачем ради этого тему на форуме создавать?)
   080808Ник
 
3 - 05.02.20 - 11:00
(0) ты пытаешься поделить дату, но делаешь это без уважения. Ты от даты отнял неопределно
   ДенисЧ
 
4 - 05.02.20 - 11:01
Отнимаешь Неопределено от даты и хочешь получить "счастье для всех даром, и пусть никто обиженный не уйдёт"?
   Temai
 
5 - 05.02.20 - 11:02
Пятнично, жаль что сегодня только среда
   Леприкон
 
6 - 05.02.20 - 11:03
(3) (4) дл меня код был написан и все прекрасно работает

я лишь применяю кусок его в скд . где он работать не желает




    Если Объект.ДоговорКонтрагента.ЛК_ОтСтавкиРефинансирования Тогда
        СРВыборка = ПолучитьСтавкиРефинансирования(тзДанные[0].ДатаПлатежа);
        Пока СРВыборка.Следующий() Цикл
            стрСР = тзДанные.Добавить();
            стрСР.ДатаПлатежа = СРВыборка.Период-24*60*60;
            //стрОплата.ПроцентПени = Окр(СРВыборка.Ставка/Объект.ДоговорКонтрагента.ЛК_ПроцентПеней,6);

        КонецЦикла;
    КонецЕсли;
    
    тзДанные.Свернуть("ДатаПлатежа","СуммаПлатежа,СуммаОплаты");
    тзДанные.Колонки.Добавить("СуммаЗадолженности", Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(15,2)));
    тзДанные.Колонки.Добавить("КоличествоДнейПросрочки", Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(10,0)));
    тзДанные.Колонки.Добавить("ПроцентПени", Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(15,6)));
    тзДанные.Колонки.Добавить("СуммаПени", Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(15,2)));
    
    Если Объект.ДоговорКонтрагента.ЛК_ОтСтавкиРефинансирования Тогда
        тзДанные = НайтиСтавкуРефинансированииДляКаждойДаты(тзДанные);
    КонецЕсли;
    
    тзДанные.Сортировать("ДатаПлатежа");
    
    ТекДата = Неопределено;
    ТекЗадолженность = 0;
    Для Каждого стр из тзДанные Цикл
        Если НЕ Объект.ДоговорКонтрагента.ЛК_ОтСтавкиРефинансирования Тогда
            стр.ПроцентПени = Объект.ДоговорКонтрагента.ЛК_ПроцентПеней;
        Иначе
            стр.ПроцентПени = Окр(стр.ПроцентПени/Объект.ДоговорКонтрагента.ЛК_ПроцентПеней,6);
        КонецЕсли;    
        Если ТекДата <> Неопределено И ТекЗадолженность > 0 Тогда
            стр.КоличествоДнейПросрочки = (стр.ДатаПлатежа - ТекДата)/(24*60*60);    
        КонецЕсли;    
        
        //стрНов = Объект.ОсновныеДанные.Добавить();


        стр.СуммаПени = стр.КоличествоДнейПросрочки*стр.ПроцентПени*ТекЗадолженность/100;
        стр.СуммаЗадолженности = ТекЗадолженность + стр.СуммаПлатежа - стр.СуммаОплаты;
        //стрНов.ДолгПоЛП = ТекЗадолженность + стр.СуммаПлатежа - стр.СуммаОплаты;


        Если стр.ДатаПлатежа > Объект.Дата Тогда
            стр.КоличествоДнейПросрочки = 0;
            стр.СуммаПени = 0;
            стр.СуммаЗадолженности = 0;
        КонецЕсли;
   Йохохо
 
7 - 05.02.20 - 11:05
(6) там после КонецЕсли; самое интере
   Леприкон
 
8 - 05.02.20 - 11:12
Вопрос как преобразовать дату в количество дней? от начала года
   1Сергей
 
9 - 05.02.20 - 11:14
(8) ДеньГода()
   acht
 
10 - 05.02.20 - 11:25
(6) а СКД-то где, Андрей Николаевич?

И да, при переходе задолжности через 1 января, вас, вместе с количеством дней от начала года, ждут интересные эффекты.

https://its.1c.ru/db/metod8dev/content/2413/hdoc что-ли посмотрите.
   Леприкон
 
11 - 05.02.20 - 11:36
(10) что то полезное от вас услышал  сегодня
   Дмитрий
 
12 - 05.02.20 - 11:39
(6) может работает в этом коде потому, что 
Если ТекДата <> Неопределено
?
   Михаил Михайлович
 
13 - 05.02.20 - 11:40
(11) толку только ноль
   Леприкон
 
14 - 05.02.20 - 11:43
(12) возможно
   Леприкон
 
15 - 05.02.20 - 11:43
(13) у вас
   Йохохо
 
16 - 05.02.20 - 11:48
Если ТекДата <> Неопределено И ТекЗадолженность > 0 Тогда// 

стр.КоличествоДнейПросрочки = (стр.ДатаПлатежа - ТекДата)/(24*60*60);    
Иначе
стр.КоличествоДнейПросрочки = 0;
КонецЕсли;
   Михаил Михайлович
 
17 - 05.02.20 - 11:54
(15) тупой копипаст, вот и результат
   palsergeich
 
18 - 05.02.20 - 12:00
(8) Есть замечательная функция языка 1с
Называется ДеньГода()
А то что в теме, я даже не знаю как назвать
   acht
 
19 - 05.02.20 - 12:01
(11) Это вы там не лизинг программируете, надеюсь?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.