Вход | Регистрация
 

Намекните, где сохранить настройки обработки?

Намекните, где сохранить настройки обработки?
Я
   Гений 1С
 
03.02.20 - 15:34
Т.е. конфа базовая, я делаю внешнюю обработку, хочу сохранить настройки. Как это делается?
Причем настройки общие для всех пользователей, а не текущего.
Что-то такое должно быть, нутром чую.
   1Сергей
 
1 - 03.02.20 - 15:35
Дополнительные реквизиты не предлагали ещё?
   Масянька
 
2 - 03.02.20 - 15:36
(0) СохранитьНастройки(), ВосстановитьНастройки().
Только это не свои данные, а настройки отчета, обработки.
   1Сергей
 
3 - 03.02.20 - 15:37
(2) это работает в пределах одного пользователя, емнип
   Гений 1С
 
4 - 03.02.20 - 15:38
упс, кажишь нашел: https://1c-programmer-blog.ru/programmirovanie/xranilishhe-nastroek-v-1s.html


ХранилищеОбщихНастроек.Сохранить
   vicof
 
5 - 03.02.20 - 15:38
"Намекните, куда курить по поводу хранения своих данных в базе 1С."
В сторону курсов профессионала по платформе
   Гений 1С
 
6 - 03.02.20 - 15:38
(5) спасибо, я уже специалист.
   unenu
 
7 - 03.02.20 - 15:40
реклама блога прокатила
   Ненавижу 1С
 
8 - 03.02.20 - 15:41
(6) видно какой ты специалист
   Масянька
 
9 - 03.02.20 - 15:41
(7) А потом - людям не помогают...
   Гений 1С
 
10 - 03.02.20 - 15:42
(8) а че, сертификат имеется. По платформе.
   hhhh
 
11 - 03.02.20 - 15:59
(10) от 2001 года?
   fisher
 
12 - 03.02.20 - 16:02
Эх, давненько не было "мой гений дарит Вам...".
Где "деревья Осипова"? Где мясо? Где былой задор?
Пора звание отбирать...
   pechkin
 
13 - 03.02.20 - 16:20
кури лучше бсп - там все есть
   pechkin
 
14 - 03.02.20 - 16:20
и настройки там немного по другому сохраняются
   Chameleon1980
 
15 - 03.02.20 - 18:15
Сделай рс свой, если нет типового типа сохранённые настройки
   rozer76
 
16 - 03.02.20 - 21:26
В БСП настойки внешней обработки обычно сохраняю в штатный рекв спр Внешниеобрабтки, не вспомню сейчас точно как называется но тип хранилищезнаяений
   1СHИK78
 
17 - 04.02.20 - 09:55
(8) Вопрос. В вакансиях пишут "Наличие сертификатов приветствуется". Это для чего пишут в основном? Чтобы отсеять бездельников (человек, у которого сертификаты, будет красть рабочее время на учебу и сдачу сертификатов) или все таки для того чтобы отсеять совсем совсем начинающих?
   fisher
 
18 - 04.02.20 - 12:01
(17) Зачем искать двойное дно? "Приветствуется" - значит, приветствуется. Это не критерий отсева. Это "дополнительные баллы" при прочих равных. И гарантия того, что стартовый отсев (на котором HR фильтрует полный шлак) ты по-любому проходишь.
   Cyberhawk
 
19 - 04.02.20 - 12:07
В реквизите справочника, который хранит подключаемые обработки
   Гений 1С
 
20 - 08.02.20 - 15:26
Работает. На всякий случай выкладываю код:

&НаКлиенте
Процедура SSH_IPАдресПриИзменении(Элемент)
    СохранитьНастройкуФормы("SSH_IPАдрес");
КонецПроцедуры

&НаКлиенте
Процедура SSH_ЛогинПриИзменении(Элемент)
    СохранитьНастройкуФормы("SSH_Логин");
КонецПроцедуры

&НаКлиенте
Процедура SSH_ПарольПриИзменении(Элемент)
    СохранитьНастройкуФормы("SSH_Пароль");
КонецПроцедуры

&НаКлиенте
Процедура SSH_ПортПриИзменении(Элемент)
    СохранитьНастройкуФормы("SSH_Порт");
КонецПроцедуры

&НаКлиенте
Процедура SSH_ПутьДоКорневойДиректорииПриИзменении(Элемент)
    СохранитьНастройкуФормы("SSH_ПутьДоКорневойДиректории");
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ВосстановитьНастройкуФормы("SSH_IPАдрес");
    ВосстановитьНастройкуФормы("SSH_Логин");
    ВосстановитьНастройкуФормы("SSH_Пароль");
    ВосстановитьНастройкуФормы("SSH_Порт");
    ВосстановитьНастройкуФормы("SSH_ПутьДоКорневойДиректории");
КонецПроцедуры

&НаСервере
Функция СохранитьНастройкуФормы(ИмяНастройки) Экспорт
    ХранилищеОбщихНастроек.Сохранить("SSH_Обмен_Битрикс_1С", ИмяНастройки, Вычислить(ИмяНастройки));
КонецФункции


Функция ВосстановитьНастройкуФормы(ИмяНастройки);
    Зн = ХранилищеОбщихНастроек.Загрузить("SSH_Обмен_Битрикс_1С", ИмяНастройки);
    Выполнить(ИмяНастройки + " = Зн");
КонецФункции

Не знаю, как к реквизиту формы обратиться по имени, гггг...
   Salimbek
 
21 - 08.02.20 - 20:38
(20) Зайди отладкой в нужную процедуру и там смотри Объект, ЭтотОбъект, ЭтаФорма и какие у них реквизиты. Где-то там :-)
   Гений 1С
 
22 - 08.02.20 - 22:01
(21) а да, точно, ЭтаФорма[ИмяРеквизита]. Склероз


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.