Вход | Регистрация
 

Вопрос по обмену между УТ 11.3 и Бухгалтерией 3

Вопрос по обмену между УТ 11.3 и  Бухгалтерией 3
Я
   Starikashka
 
03.02.20 - 10:25
Настроен типовой обмен.
  Из Бух в УТ переносится документ поступление денежных средств.
  Задача:
  1. Документ Поступление ДС в любом случае не переносится из УТ в БУХ.
  2. если в УТ в документе ПоступлениеДС выставлен вручную некий признак (галка) , то документ не обновляется из Бух в УТ.

  Первая часть решена. Выгрузил правила регистрации из УТ и поставил Отказ = Истина; в обработчике передОбработкой.
  
  Как реализовать вторую часть ?
  В бухгалтерии не могу найти правила регистрации.
   unbred
 
1 - 03.02.20 - 10:36
так же как первую.
   Starikashka
 
2 - 03.02.20 - 10:43
(1) а можно подробнее ?
   unbred
 
3 - 03.02.20 - 10:46
Если ТвойФлаг Тогда
Выгрузил правила регистрации из УТ и поставил Отказ = Истина; в обработчике передОбработкой
КонецЕсли;
   unbred
 
4 - 03.02.20 - 10:46
только уже БП)
   Starikashka
 
5 - 03.02.20 - 10:58
(4) Вопервых я в бух не могу найти правила регистрации.
    В УТ - НСИ и Адм - Интеграция - Синхронизация данных - НастройкиСинхронизации - Настроить- ПараметрыСинхронизации - ЗагрузитьПравила регистрации объектов
и там можно выгрузить правила.
    В бух по этому пути нету "Загрузить Правила"
   Starikashka
 
6 - 03.02.20 - 11:24
Во !!!
  Нашел. Они же в регистресведений :)
  Сейчас исправлю чего нибудь
   Starikashka
 
7 - 07.02.20 - 16:00
Где находятся правила я нашел, только не совсем разобрался как нужно их исправить , чтобы решить задачу.
  Если как сказано в (3) попытаться 
  Если Объект.ТвойФлаг Тогда
       Отказ = Истина;
  КонецЕсли;

  То так негодится. Объект то из Бух базы, а флаг есть в торговой базе.
   Фрэнки
 
8 - 07.02.20 - 16:31
для правил регистрации пытаешься составить условия по несуществующим в текущей базе признакам
   Starikashka
 
9 - 07.02.20 - 16:38
(8) Вроде как посоветовали.
    Так вот я тоже думаю, что так нельзя.
    Если что то и править то в правилахУт, где есть этот признак.
    Объект.МойФлаг

    Но там и так в любом случае отказ.
   Starikashka
 
10 - 07.02.20 - 16:39
Я вот что придумал.
    В модуле документа :
 Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    Если ОбменДанными.Загрузка И МойФлаг Тогда
        Отказ = Истина;
                Возврат;
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.