Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Пробить чек ТиС 1001

v7: Пробить чек ТиС 1001
Я
   ChMikle
 
31.01.20 - 16:58
Отстал от темы, стоит древняя тис , торгуем в розницу , подлатали  старый драйвер  для штрихов чтобы посылал чеки в ОФД, обновили прошивку ККМ штрих-Лайт 2.0. Но отправляются не все реквизиты . нашел обновление ТИС , там уже обмен с кассами идет в ХМЛ формате. Поставил демку ТИС 1001, хочу пробить чек, выбрал ккм онлайн , но чек не пробивает, ставлю кассе признак фр - чеки можно пробивать только для юр.лиц! Подскажите, как теперь надо настраивать торговое оборудование , чтобы пробивать чеки в розничном магазине на ЕНВД.
   Злопчинский
 
1 - 01.02.20 - 00:51
(0) "хочу пробить чек, выбрал ккм онлайн , но чек не пробивает,"
- ну так наверное надо разобраться почему не пробивает...
   ChMikle
 
2 - 01.02.20 - 12:13
(1) спасибо за помощь, весьма исчерпывающий ответ ))
   Злопчинский
 
3 - 01.02.20 - 15:04
ну какой диагноз 2..не пробивает.." - такой и ответ
   victuan1
 
4 - 04.02.20 - 06:09
(1) Надо выбирать ККМ = ФР. "Онлайн" это для автономных (старый термин, еще до 54ФЗ).
   johnnik
 
5 - 04.02.20 - 06:49
подлатали  старый драйвер  для штрихов
---------------
Драйвер ставьте новый. Как для штрихов - хз, но для АТОЛ-лов надо положить в папку с базой .dll-ку и зарегать ее. В ТиС настроить торговое оборудование (Меню сервис, дальше не помню). Указать модель кассы и обработку обслуживания. Что-то вроде strhih-m_105.ert. Прямо из 1С можно глянуть настройки кассы (типа как из драйвера). Это будет означать, что все ок. После этого в справочнике касс указать, что ККМ онлайн, выбрать кассира и из документов ЧекККМ (меню Продажи - Розница) пробивать. Боле подробно могу только по АТОЛам, со штрихами не работал в 7.7
   Kigo_Kigo
 
6 - 04.02.20 - 07:47
то что есть в стандарте- хрень полная, ноесли розница не замороченная и нет скидок, и кассир один и не требуется разделения нал безнал- то вполне прокатит, если все это требуется - то только писать допиливать самому и не через прокладку 1с strhih-m_105.ert, а напрямую DrvFr.dll

и да что бы сча запечатало п о рознице, надо в настройках пользователя кассира по умолчанию выбрать розничный склад, кассу по умолчанию, в которой признаком стоит - касса ккм фр
   Kigo_Kigo
 
7 - 04.02.20 - 08:04
В чеке Функция ПробитьЧекНаККМ()
    Перем НомерЧека;
    
    СписокТоваров = СоздатьОбъект("ТаблицаЗначений");
    СписокТоваров.НоваяКолонка("ТовНаим"   , "Строка");
    СписокТоваров.НоваяКолонка("Цена"      , "Число");
    СписокТоваров.НоваяКолонка("ЦенаТЧ"     , "Число");
    
    СписокТоваров.НоваяКолонка("Количество", "Число");
    Если Продавец.Выбран() = 0 Тогда
        Предупреждение("Не выбран продавец!");
        Возврат 0;
    КонецЕсли;
    Если  Продавец.Пароль = 0  Тогда
        Пароль = "30";
        
    Иначе
        
        Пароль = Продавец.Пароль;
    КонецЕсли;  
    Если (ОплатаКартой = 1) и (ИтогоПоБанку = 0) Тогда
        Предупреждение("Введите сумму оплаты по банку!");
        Возврат 0;
    КонецЕсли;
    
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
        СписокТоваров.НоваяСтрока();
        СписокТоваров.ТовНаим    = СокрЛП(Номенклатура.Артикул)+ ":" + СокрЛП(Номенклатура.Наименование) ;
        СписокТоваров.Цена       = Сумма/?(Количество = 0,1,Количество);
        СписокТоваров.ЦенаТЧ       =Цена;

        СписокТоваров.Количество = Количество;
    КонецЦикла;
    
    ПризнВозврата = ?(ВидОперации = Перечисление.ВидыОперацийЧекККМ.Чек, 0, 1);
    ЧекПробитККМ  = глФРПечататьЧек(СписокТоваров, Итог("Сумма"),Итог("Сумма") , Скидка.Процент, ПризнВозврата, Склад.НомерСекции, НомерЧека,ОплатаКартой,ТекущийДокумент(),Пароль,СокрЛП(Продавец.ИНН),СокрЛП(КудаОтправитьЧек));

    Если ЧекПробитККМ = 1 Тогда
        ПриЗаписиПерепроводить(0);
        НомерЧекаККМ = НомерЧека;
        Записать();
        ПриЗаписиПерепроводить(1);
        
        // Откроем денежный ящик, если он подключен

        глДПОткрытьДенежныйЯщик();
    КонецЕсли;
    
    Возврат ЧекПробитККМ;
    
КонецФункции// ПробитьЧекНаККМ() 

//в глобальнике


Функция глФРПечататьЧек(СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, НомерСекции, НомерЧека,ОплатаКартой = 0,Док = "",Пароль = "",ИННПродавца ="",КудаОтправитьЧек ="")  Экспорт
    
    Рез = 0;
    
    Если глФРВкл = 1 Тогда
        Параметры = СоздатьОбъект("СписокЗначений");
        Параметры.Установить("Процесс"           , "печатать_чек");
        Параметры.Установить("Объект"            , глФР);
        Если ПустоеЗначение(Пароль) = 1 Тогда
            
            Параметры.Установить("ПарольПользователя", глФРПарольПользователя);
        Иначе 
            Параметры.Установить("ПарольПользователя", Пароль);
            
        КонецЕсли;
        Параметры.Установить("СписокТоваров"     , СписокТоваров);
        Параметры.Установить("СуммаЧека"         , СуммаЧека);
        Параметры.Установить("Получено"          , Получено);
        Параметры.Установить("Скидка"            , Скидка);
        Параметры.Установить("Возврат"           , ПризнВозврата);
        Параметры.Установить("НомерСекции"       , НомерСекции);
        Параметры.Установить("ПриемНаличныхОтЮрЛиц", глФРДляПриемаНаличныхОтЮрЛиц);
        Параметры.Установить("ОплатаКартой", ОплатаКартой);
        Параметры.Установить("Док", Док);
        Параметры.Установить("ИННПродавца", ИННПродавца);
        Параметры.Установить("КудаОтправитьЧек", КудаОтправитьЧек);


        РезТекст = глОборудованиеКоманда("ФР", глФРОбработка, Параметры);
        Если ПустоеЗначение(РезТекст) = 0 Тогда
            Сообщить(РезТекст);
        Иначе
            Если Параметры.Получить("Результат") = 0 Тогда
                Сообщить("Фискальный регистратор: ошибка при печати чека");
                Сообщить(Параметры.Получить("ОписаниеРезультата"));
            Иначе
                НомерЧека = Параметры.Получить("НомерЧека");
                Рез = 1;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
    
    Возврат Рез;
    
КонецФункции// глФРПечататьЧек()

  ссылка на обработку обслуживания Штрих-м онлайн для 7.7
https://yadi.sk/d/EwN57IWlnflFIQ

в чеке добавить реквизиты Оплата по банку- тип число(галка)
ИтогоПобанку тип число 15.2 , суума оплаты по банку в том числе для смешанных оплат
Продавец- тип Физ лицо, 
Куда оптрпавить чек - тип строка

у Физлица добавить тип пароль- число ИНН - строка(по моему она там уже была)
в ККМ в таблицах Кассиры прописать ФИО кассиров, в зависимость от того какой пароль передаете, того кассира и будет печатать касса, может что то забыл, далее сами, вопросы- задавайте
   ChMikle
 
8 - 04.02.20 - 09:08
Друзья , спасибо за отзывчивость! В общем, с божьей помощью и одного хорошего человека :))  удалось старую обработку работы с ФР  дописать до полной выгрузки  в ОФД. Осталось разобраться со следующим -  когда печатается итоговая сумма продажи по строке выходит: 1.......... 235_г .
Два вопроса : 1. Куда копать по поводу 1 (я так предполагаю что этого как-то можно настроить в фр чтобы не печаталось) ?
              2. _г после итоговой суммы - это что (валюта) тогда где настроить чтобы были руб. ?
   johnnik
 
9 - 04.02.20 - 09:24
(8) В ОФД чеки отправляет сам кассовый аппарат. Для этого в нем должны быть прописаны настройки ОФД, с ОФД у вас должен быть заключен договор, и в личном кабинете ОФД прописана конкретно эта касса (с рег.номерами кассы и фискального накопителя). Ну и технически на компе должен быть интернет, проброшенный на кассовый аппарат (по кабелю USB или Wi-Fi-модуль, хотя он редко встречается). Если эти условия не выполнены, то никаким способом вы в ОФД никакие чеки не отправите, если этот хороший человек не главный сисадмин ОФД :) Обработка лишь дает возможно напечатать кассовый чек, а дальше касса все сама делает.

Вопрос у вас в (7) задан так, что на него не ответить. Можно поконкретнее, лучше даже со скриншотами и фотками чека.
   Kigo_Kigo
 
10 - 04.02.20 - 09:31
(9) Ну стоит добавить , что чек должен закрываться командой Объект.FNCloseCheckEx();Что бы он ушел в ОФД, хотя в последнем драйвере по команде клосечек вроде отрабатывается полное закрытие по всем регистрам в том числе и FNCloseCheckEx();
   ChMikle
 
11 - 04.02.20 - 10:03
(9)(10) Все в офд уходит нормально :), уже проверяли , до этого не выгружалась налоговая группа , посетитель(дай бог ему здоровья) этого форума скинул описание драйвера ККМ и разобрался :)), наверное этот вопросы к прошивке ккм и работникам ЦТО .
когда печатается чек то печатается товар ,количество*цена, ниже печатается итоговая сумма продажи по позиции .
вот там почему то слева 1..... итоговая сумма продажи по товару и после суммы выводится "_г".
   ChMikle
 
12 - 04.02.20 - 10:19
cloud.mail.ru/public/6tkm/XDBiWkAmG фото чека
   ChMikle
 
13 - 04.02.20 - 10:45
   Kigo_Kigo
 
14 - 04.02.20 - 11:00
(13) "1" это подитог по секции, не обращай внимания
   Kigo_Kigo
 
15 - 04.02.20 - 11:05
А по поводу "_г" первый раз такое виже, но и это не твое дело - пусть обращаются В ЦТО или там где приобретали ККТ, пусть там разбираются
   Trotter
 
16 - 04.02.20 - 11:25
Кассир - сист. администратор. Так нельзя. ФИО должно быть
   Trotter
 
17 - 04.02.20 - 11:26
_г - это сноска, что без НДС, это норм. нужно уточнить про буквы "сноса"
   ChMikle
 
18 - 04.02.20 - 12:40
(16) это мы пробивали тестовый чек , так-то там фио кассира .
(17) а из печати ее убирают уже путем ковыряния в настройках ККМ ?
   Kigo_Kigo
 
19 - 04.02.20 - 12:43
(18) Да эта настройка чисто ККМ
   ChMikle
 
20 - 04.02.20 - 12:49
понял , всем спасибо !
   victuan1
 
21 - 04.02.20 - 12:50
1 - это номер секции (отдела), можно нужный номер передать программно. Можно отключить вывод настройками в Тесте драйвера ФР
г - код ставки НДС (а, б, в, г). Зачем отключать? Никому не мешает, хотя настройками можно тоже убрать или заменить на печать ставки НДС.
   ChMikle
 
22 - 04.02.20 - 14:20
(21) а вообще убрать печать кода ставки из чека можно ,там ЕНДВ и _г после суммы как-то не очень серьезно выглядит?
   victuan1
 
23 - 05.02.20 - 05:51
(22) Надо искать в Настройках драйвера. Или спросить сервисный центр по обслуживанию ККМ, т.к. эти настройки можно внести не программируя модуль печати чека.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.