Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод значений в поле выбора формы

Вывод значений в поле выбора формы
Я
   Tenyx
 
30.01.20 - 23:41
Доброго времени суток, начинаю изучать 1С, требуется помощь.
Есть справочник Поставщики. Необходимо, чтобы наименования поставщиков загружались в поле выбора(выпадающий список) на форме обработки. Есть поле Поставщик, путь к данным которого - Поставщик1.Наименование (Поставщик1 - реквизит этой формы с типом Справочник.Ссылка.Поставщики). Заполняю список выбора программно, но в итоге поле так и остается пустым. Код отрабатывает нормально и при отладке я вижу успешное заполнение списка выбора. К тому же, даже при заполнении списка через свойства поле так и остается пустым. Что может быть не так? (на всякий случай код приложу все же)

&НаСервере
Функция ВыводИмени()                                                
    Запрос = Новый Запрос;
    Запрос.Текст="ВЫБРАТЬ
    |    Поставщики.Наименование
    |ИЗ
    |    Справочник.Поставщики КАК Поставщики";
    Запр = Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Наименование");
    Возврат Запр;
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Имя = ВыводИмени();
    Для каждого Значение из Имя Цикл
        Элементы.Поставщик.СписокВыбора.Добавить(Значение);
    КонецЦикла;
КонецПроцедуры
 
 
   Tenyx
 
1 - 31.01.20 - 00:02
Проблема решена! Полазал по форуму и понял, что у реквизита должен был быть тип значения Произвольный.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.