Вход | Регистрация
 

Метод объекта не обнаружен при ссылке на документ где есть такая экспортная функция УТ10.3

Метод объекта не обнаружен при ссылке на документ где есть такая экспортная функция УТ10.3
Я
   Shecurok
 
30.01.20 - 09:59
Добавил форму в документ, в форме сделал реквизит ссылка на объект РеализацияТоваровУслуг. В форме по нажатию кнопки должна вызываться функция из модуля документа РеализацияТоваровУслуг.

Ошибка выглядит так:
{Документ.РеализацияТоваровУслуг.Форма.Форма.Форма(7)}: Метод объекта не обнаружен (ПечатьДоверенности)
СсылкаНаОбъект.ПечатьДоверенности();

Процедура кнопки выглядит так:
Функция Кнопка2Нажатие(Элемент)
    
    ДоверенноеЛицо = "---";
    Доверенность   = "(По доверенности № 02/20-ГС от 09 января 2020 года)";                
    СсылкаНаОбъект.ПечатьДоверенности();
    ЭтаФорма.Закрыть();    
    
КонецФункции

Скрыть


Функция выглдяит так в документе:
Функция ПечатьДоверенности() Экспорт
ТабДокумент = ПечатьУниверсальногоПередаточногоДокумента();
УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, , , ОбщегоНазначения.СформироватьЗаголовокДокумента());

КонецФункции



Почему не видит её?
   Ненавижу 1С
 
1 - 30.01.20 - 10:01
СсылкаНаОбъект какого типа?
   Cyberhawk
 
2 - 30.01.20 - 10:02
Надо получить объект от ссылки и у объекта вызывать метод, а не у ссылки
   Shecurok
 
3 - 30.01.20 - 10:02
(1) ссылочного. ДокументСсылка.РеализацияТоваровУслуг
   Shecurok
 
4 - 30.01.20 - 10:03
(2) Сделать ссылку на ДокументОбъект?
   Ненавижу 1С
 
5 - 30.01.20 - 10:04
(3) и когда у ссылок появилась возможность создавать свои методы?
   Shecurok
 
6 - 30.01.20 - 10:04
(5) изменил, ошибка другая стала:

{Документ.РеализацияТоваровУслуг.Форма.Форма.Форма(7)}: Значение не является значением объектного типа (ПечатьДоверенности)
    СсылкаНаОбъект.ПечатьДоверенности();
   Ненавижу 1С
 
7 - 30.01.20 - 10:05
(4) нет, надо метод перенести в модуль менеджера и его вызывать, передавая ссылку как параметр
   Shecurok
 
8 - 30.01.20 - 10:09
(7) не понял немног :с
   ДенисЧ
 
9 - 30.01.20 - 10:13
(8) Какую из букв не понял?
   Shecurok
 
10 - 30.01.20 - 10:15
(9) я не знаю как метод перенести в модуль менеджера. Ну копировать вставить это ладно, но там же вызывается процедура из модуля объекта, а как поменять хз
   ДенисЧ
 
11 - 30.01.20 - 10:16
(10) Ну так вызывай эту функцию... В менеджерной функции получай объект по переданной ссылке и вызывай...
   hhhh
 
12 - 30.01.20 - 10:39
(10) как получаешь СсылкаНаОбъект и посмотри всё таки его тип в отладчике
   Shecurok
 
13 - 30.01.20 - 10:43
попробовал так:

Функция Кнопка1Нажатие(Элемент)
    
    ДоверенноеЛицо = "--";
    Доверенность   = "(По доверенности № 03/20-АП от 09 января 2020 года)";

    ДокОбъект = СсылкаНаОбъект.ПолучитьОбъект();
    ДокОбъект.ПечатьДоверенности();
    ЭтаФорма.Закрыть(); 

    
КонецФункции

{Документ.РеализацияТоваровУслуг.Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
    ДокОбъект = СсылкаНаОбъект.ПолучитьОбъект();
по причине:
Элемент не выбран!
   Shecurok
 
14 - 30.01.20 - 10:44
новая ошибка
   catena
 
15 - 30.01.20 - 10:47
(13)Ты посмотрел в отладчике, какого типа СсылкаНаОбъект и что в ней лежит?
   hhhh
 
16 - 30.01.20 - 10:48
(14) ну вставь Сообщить("" + СсылкаНаОбъект + ": " + ТипЗнч(СсылкаНаОбъект));
   Shecurok
 
17 - 30.01.20 - 10:52
(15) странно, но ничего судя по всему. Ставлю точку останова на этой строчке, она срабатывает, но ничего нет в ссылке на объект
   hhhh
 
18 - 30.01.20 - 10:54
(17) а точно там что-то должно быть? может вы туда ничего не записывали?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.