Вход | Регистрация
 

Вопрос По событию при выводе строки

Вопрос По событию при выводе строки
Я
   Nemirov
 
30.01.20 - 08:19
Вопрос такой: Событие  ПриВыводеСтроки не срабатывает, точкой остановы прогонял не понимаю в чем причина. Событие срабатывает только в том случае как только попытаешься изменить размер колонки в ручную. Вот код ширину взял к примеру:


Процедура НоменклатураНажатие(Кнопка,Элемент)
    
    Номен = Истина;
    Док = Ложь;

Запрос=Новый Запрос();
    Запрос.Текст="ВЫБРАТЬ
                 |    РасходнаяНакладнаяСостав.Номенклатура КАК Номенклатура,
                 |    ЕСТЬNULL(ПриходнаяНакладнаяСостав.Количество, 0) - РасходнаяНакладнаяСостав.Количество   КАК Разница,
                 |    РасходнаяНакладнаяСостав.Ссылка КАК Документ
                 |ИЗ
                 |    Документ.РасходнаяНакладная.Состав КАК РасходнаяНакладнаяСостав
                 |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПриходнаяНакладная.Состав КАК ПриходнаяНакладнаяСостав
                 |        ПО РасходнаяНакладнаяСостав.Номенклатура = ПриходнаяНакладнаяСостав.Номенклатура
                 |            И РасходнаяНакладнаяСостав.Ссылка = ПриходнаяНакладнаяСостав.Ссылка.ДокОснование
                 |ГДЕ
                |    РасходнаяНакладнаяСостав.Количество - ЕСТЬNULL(ПриходнаяНакладнаяСостав.Количество, 0) <> 0
                 |     И РасходнаяНакладнаяСостав.Ссылка.Контрагент ССЫЛКА Справочник.СтруктурныеЕдиницы
                 |    И (&НеПроверятьДата
                 |            ИЛИ РасходнаяНакладнаяСостав.Ссылка.Дата МЕЖДУ &ДатаНач И &ДатаКон)
                 |    И (&НеПроверятьКонтрагент
                 |            ИЛИ РасходнаяНакладнаяСостав.Ссылка.Контрагент = &СтруктурнаяЕдиница)
                |    И РасходнаяНакладнаяСостав.Ссылка.Проведен = ИСТИНА
               //  |    И ПриходнаяНакладнаяСостав.Ссылка.Проведен = ИСТИНА
                 |";
    Если НЕ ПараметрыСеанса.ТекущаяСтруктурнаяЕдиница = Справочники.СтруктурныеЕдиницы.НайтиПоКоду("1")Тогда
        ЭлементыФормы.Контрагент.Значение = ПараметрыСеанса.ТекущаяСтруктурнаяЕдиница;
        ЭлементыФормы.Контрагент.Доступность = ЛОЖЬ;
    КонецЕсли;
    //Запрос.УстановитьПараметр("МоментВремени",ТекущаяДатаСеанса());
    Запрос.УстановитьПараметр("ДатаНач",НачалоДня(ДатаНач));
    Запрос.УстановитьПараметр("ДатаКон",КонецДня(ДатаКон));
    Запрос.УстановитьПараметр("СтруктурнаяЕдиница",Контрагент);
    
    Если Не ЗначениеЗаполнено(Контрагент) Тогда
        Запрос.УстановитьПараметр("НеПроверятьКонтрагент", Истина);

    Иначе
        Запрос.УстановитьПараметр("НеПроверятьКонтрагент", Ложь);
    КонецЕсли;    
    Если Не ЗначениеЗаполнено(ДатаНач) Тогда
        Запрос.УстановитьПараметр("НеПроверятьДата", Истина);
    Иначе
        Запрос.УстановитьПараметр("НеПроверятьДата", Ложь);
    КонецЕсли;    
    Если Не ЗначениеЗаполнено(ДатаКон) Тогда
        Запрос.УстановитьПараметр("НеПроверятьДата", Истина);
    Иначе
        Запрос.УстановитьПараметр("НеПроверятьДата", Ложь);
    КонецЕсли;
    Документы=Запрос.Выполнить().Выгрузить();
    ЭлементыФормы.Документы.СоздатьКолонки();
    //Элемент.Колонки.Разница.Ширина = 2;
КонецПроцедуры

Процедура ДокументыВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    ОткрытьЗначение(ВыбраннаяСтрока.Документ.Ссылка);
    
КонецПроцедуры

Процедура ПриОткрытии()
    
    Если НЕ ПараметрыСеанса.ТекущаяСтруктурнаяЕдиница = Справочники.СтруктурныеЕдиницы.НайтиПоКоду("1")Тогда
        ЭлементыФормы.Контрагент.Значение = ПараметрыСеанса.ТекущаяСтруктурнаяЕдиница;
        ЭлементыФормы.Контрагент.Доступность = ЛОЖЬ;
    КонецЕсли;    
    ЭлементыФормы.ДатаНач.Значение= (НачалоМесяца(ТекущаяДата()));
    ЭлементыФормы.ДатаКон.Значение= (КонецМесяца(ТекущаяДата()));
    
КонецПроцедуры

Процедура ДокументыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Элемент.Колонки.Разница.Ширина = 2;
КонецПроцедуры
   Nemirov
 
1 - 30.01.20 - 08:21
Пробовал и ПриПолученииДанных
та же самя песня
Событие отрабатывается только при попытке сделать что нибуть с колонкой
   Галахад
 
2 - 30.01.20 - 08:23
Почему именно эта процедура выбрана для изменения ширины клоноки?
   Nemirov
 
3 - 30.01.20 - 08:25
(2) Чисто для примера. Давайте ваш вариант попробуем...
   Nemirov
 
4 - 30.01.20 - 08:30
Через точку остановы, в локальных переменных колонка принимает заданную ширину, но на форме она не изменяется, размеры по умолчанию...
   Ёпрст
 
5 - 30.01.20 - 08:30
(3) в номенклатура нажатие пихай в конец + табполе обнови на ыорме потом
   Nemirov
 
6 - 30.01.20 - 08:41
(5) Ну в принципе тоже отличный варик, спасибо!!! Часто выручаешь и терпишь меня студента ахах. Отдельный тебе памятник!
   Nemirov
 
7 - 30.01.20 - 08:43
(5) А еще вопрос как текст выровнять по горизонтальному положению в колонке? Не могу вдуплить и по точке останова не могу найти. Гугл кашу  выдает. Допустим тот же Элемент.Колонки.Разница текст центрировать или левее правее выставить. Есть вообще способ?
   Nemirov
 
8 - 30.01.20 - 08:45
Дабы не создавать отдельную тему с тупеньким вопросом xD
   catena
 
9 - 30.01.20 - 08:47
КолонкаТабличногоПоля (TableBoxColumn)
ГоризонтальноеПоложениеВКолонке (HorizontalAlignInColumn)
Использование:

Чтение и запись.
Описание:

Тип: ГоризонтальноеПоложение.
Определяет способ горизонтального расположения текста в колонке.
   Nemirov
 
10 - 30.01.20 - 08:48
(9) Странно почему синт помошник не выдал мне это(

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.