Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Formex, сделал CTRL+P как нажатие кнопки ВПФ "Печать", глюк странный...

v7: Formex, сделал CTRL+P как нажатие кнопки ВПФ "Печать", глюк странный...
Я
   Злопчинский
 
30.01.20 - 03:48
Есть обычная форма (список справочника).
Есть обычный типовой ТИСовский механизм ВПФ (кнопка выбора ВПФ + кнопка печати текущей ВПФ).
Захотелось (работаем с клавы) чтобы по нажатию CTRL+P отрабатывало как нажатие кнопки "Печать"..
однако наблюдается ГЛЮК (?). если раскладка клавы ENG - то все работает как задумывалось, ок.
А вот если клава = RU, то регулярно (но не всегда!) выскакивает окно предупреждения "Доступ к файлу <тутимяВПФ> закрыт" с кнопкой "ОК", давим кнопку ОК - дальше все работает норм - формируется ВПФ итд...
Что это за..?
.
Код:
.
//******************************************************************************
// FORMEX
Процедура ПриНажатииКнопкиКлавиатуры(код, _а, _ш, _к, символ, ФСО)

    Если _к=1 Тогда
        Если ПустаяСтрока(символ)=0 Тогда
            Если Найти(Симв(16),символ)>0 Тогда ФСО = 0; ПоКнопкеПечать(); Возврат; КонецЕсли;
        КонецЕсли;    
    КонецЕсли;
   victuan1
 
1 - 30.01.20 - 05:06
Отладчик что говорит?
   Ёпрст
 
2 - 30.01.20 - 08:33
(0) приотжатии, для начала
   Ёпрст
 
3 - 30.01.20 - 08:34
И формекс там не нужен, емли что. Повесь хот кей на невидимую кнопку на форме, это работать будет везде
   8 bit
 
4 - 30.01.20 - 08:37
(0) Есть подозрение, что где-то уже используется сочетание Ctrl+з (русская зе). А еще есть подозрение, что регистр влияет (CapsLock), например.
   Масянька
 
5 - 30.01.20 - 08:44
(3) +100.
(0) У меня есть опыт того, что раскладка в семерке очень значима. Попробуй сделать в двух вариантах - русская и латиница.
   ADirks
 
6 - 30.01.20 - 08:59
ну и плюс к вышесказанному

Если Код = КодСимв("P") Тогда
   Злопчинский
 
7 - 30.01.20 - 13:33
(3) штатно Ctrl+P на кнопку..?
   Злопчинский
 
8 - 30.01.20 - 13:34
Почему Приотжатии? везде работает именно на нажатие кнопки.?
   Злопчинский
 
9 - 30.01.20 - 13:35
Меня вообще код в (0) удивляет - как это вообще работает?
там вообще не упоминается у меня P/З
   victuan1
 
10 - 30.01.20 - 17:28
(7) Через i-gent я обычно назначаю любые сочетания.
Кстати, ты заметил, что у меня в Панели управления ККМ можно менять мышкой размеры ТЗ на ее форме (в режиме Предприятие) и некоторых других контролов? И то что кнопки на закладке "Сервис" имеют более жирную рамку, чем обычные кнопки? ;))
Без всяких ВК.
   victuan1
 
11 - 30.01.20 - 17:44
   Ёпрст
 
12 - 31.01.20 - 11:48
(8) При зажатой кнопке твой код..немерянно раз выполнится
   Злопчинский
 
13 - 31.01.20 - 14:17
(12) учтем.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.