Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Выгрузка отчета оборотки в CSV

Выгрузка отчета оборотки в CSV
Я
   lirt82
 
28.01.20 - 15:24
Колеги подскажите, как выгрузить данные отчета оборотка в файл CSV, отчет оборотку сделал внешним, на форме добавил кнопку и процедуру ниже. т..е мне нужно выгрузить результат из формы отчета в ТЗ ? или иначе преобразовывать данные?

Процедура КоманднаяПанельФормыCSV(Кнопка)

    ТЗЭкспорт = ЭлементыФормы.ДокументРезультат.Выгрузить();
    
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    Диалог.Заголовок = "Выберите файл";
    Диалог.ПолноеИмяФайла = "";
    Диалог.ПредварительныйПросмотр = Ложь;
    Диалог.Фильтр =
    " (*.csv)|*.csv";
    Если Диалог.Выбрать() Тогда
        Текст = Новый ТекстовыйДокумент;
        Пока ЭлементыФормы.ДокументРезультат.Следующий Цикл
            Текст.ДобавитьСтроку();
        КонецЦикла;
        Текст.Записать(Диалог.ПолноеИмяФайла);
    Иначе
        Возврат;
    КонецЕсли;    
    
КонецПроцедуры

ВнешнийОтчет.ОборотноСальдоваяВедомостьТиповой.Форма.ФормаОсновная.Форма(434)}: Метод объекта не обнаружен (Выгрузить)
    ТЗЭкспорт = ЭлементыФормы.ДокументРезультат.Выгрузить();
 
 
   ChMikle
 
1 - 28.01.20 - 15:35
сохранить печатную форму в файл в нужном формате не подойдет ?
   Kigo_Kigo
 
2 - 28.01.20 - 15:42
Что вы пытаетесь вложить сокральный смысл в csv, это всего лишь ТЕКСТ сразделителем ";" вот и работаейте с ним как с простым текстом, ошибка ваша тут не причем, она у вас не видит коллекцию для ДокументРезультат выгрузки из него
   lirt82
 
3 - 28.01.20 - 17:12
(1) не понял, как?
   unenu
 
4 - 28.01.20 - 17:17
автор путает теплое с мягким, пока предлагаю ему не мешать
   Garykom
 
5 - 28.01.20 - 17:18
(2) >csv, это всего лишь ТЕКСТ сразделителем ";"

Это не так
   ChMikle
 
6 - 28.01.20 - 17:24
(0) оборотку сформируйте , будет пункт меню сохранить как и сохраните в нужном вам формате , нет csv, в ексель , а из екселя в csv
   lirt82
 
7 - 28.01.20 - 17:30
(6) ну так и сделал:)
   ChMikle
 
8 - 28.01.20 - 17:36
(7) быстро , не затратно :))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.