Вход | Регистрация
 

Вопрос по процедуре

↓ [Волшебник, 28.01.20 - 12:06]
Вопрос по процедуре
Я
   Nemirov
 
28.01.20 - 12:03
Процедура ДокументыВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Если    //"Что тут должно быть"//
Тогда
    ОткрытьЗначение(ВыбраннаяСтрока.Документ.Ссылка);
Иначе
    ОткрытьЗначение(ВыбраннаяСтрока.ДокументПриходная.Ссылка);
    КонецЕсли;
КонецПроцедуры



//Пробовал
Если    ВыбраннаяСтрока.Документ  Тогда
    ОткрытьЗначение(ВыбраннаяСтрока.Документ.Ссылка);
Иначе
    ОткрытьЗначение(ВыбраннаяСтрока.ДокументПриходная.Ссылка);
    КонецЕсли;
//// Преобразование значения к типу Булево не может быть выполнено
    Если    ВыбраннаяСтрока.Документ  Тогда////
   ДенисЧ
 
1 - 28.01.20 - 12:05
Нам отсюда не видно, какого типа у тебя ВыбраннаяСтрока.Документ.
Но, судя по ОткрытьЗначение(ВыбраннаяСтрока.Документ.Ссылка) - явно не булево...
   Franchiser
 
2 - 28.01.20 - 12:05
Если ЗначениеЗаполнено(ВыбраннаяСтрока.Документ) Тогда

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.