Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ 10.3. В чеке печатается всегда количество 1. Хотя в счете, например 5. Это настройка ?

УТ 10.3. В чеке печатается всегда количество 1. Хотя в счете, например 5. Это настройка ?
Я
   Румата
 
28.01.20 - 09:35
10.3.57.2.  Заводим счет на оплату, в нем кабель в количестве 5 метров по 20 рублей за метр. На основании счета делаем ПКО и пробиваем из него чек. В чеке кабеля 1 по цене 100 рублей. Кто сталкивался ?
 
 
   Йохохо
 
1 - 28.01.20 - 09:39
мм, тестовый режим драйверов атол?
   Румата
 
2 - 28.01.20 - 09:44
(1) Атол 30Ф, где посмотреть тестовый режим драйверов ? )
   tixis
 
3 - 28.01.20 - 09:50
Думаю если бы был тестовый режим драйверов, то и сумма везде была бы одинаковая, скорее всего в обработке оборудования зашили 1, а сумму правильную ставят.
   Йохохо
 
4 - 28.01.20 - 09:52
(2) чтото не могу найти
+ (3) второй признак не более 10 товаров в чеке афаир, проверьте
   Kigo_Kigo
 
5 - 28.01.20 - 09:53
(3) И скорее всего- это сделано чтобы не морочится со скидками, колво-"1",цена =сумма
   Румата
 
6 - 28.01.20 - 09:54
Версия API 2,05
Версия обработки 3,02
   Йохохо
 
7 - 28.01.20 - 09:56
(6) фискальный признак есть?
   Румата
 
8 - 28.01.20 - 10:00
(7) Есть. Можете подсказать в какой процедуре формируется таблица товаров для вывода в чек ? В обработке ТОСЕРВЕР ?
   Румата
 
9 - 28.01.20 - 10:06
Вот нашел в модуле обработки ТОСЕРВЕР :


Функция ПечатьЧекаПКОРКО(Идентификатор, ЭтоРКО, Пароль, НомерЧека, НомерСмены,
                         ОписаниеПлатежа, СуммаНал, СуммаБезнал)

....

Для Каждого Позиция Из ОписаниеПлатежа Цикл
                    Результат = Обработка.ПечататьСтроку(Объект,
                                                         Позиция.Заголовок,
                                                         1,
                                                         Позиция.Сумма,
                                                         0,
                                                         НомерОтдела,
                                                         Позиция.НДС);
=================

Может я какие-то параметры не правильно передаю, что он этот код обрабатывает ?
   Румата
 
10 - 28.01.20 - 10:28
Вот нашел в общем модуле ДенежныеСредстваСервер :

ВыборкаАвансов = РезультатЗапроса[3].Выбрать();
    Пока ВыборкаАвансов.Следующий() Цикл
        
        СтрокаПозицииЧека = МенеджерОборудованияКлиентСервер.ПараметрыФискальнойСтрокиЧека();
        СтрокаПозицииЧека.ПризнакСпособаРасчета  = Перечисления.ПризнакиСпособаРасчета.Аванс;
        СтрокаПозицииЧека.ПризнакПредметаРасчета = Перечисления.ПризнакиПредметаРасчета.ПлатежВыплата;
        
        Если ДанныеДокумента.ТипРасчета = Перечисления.ТипыРасчетаДенежнымиСредствами.ПриходДенежныхСредств Тогда
            СтрокаПозицииЧека.Наименование = НСтр("ru = 'Оплата от:'")
                + " " + ДанныеДокумента.ПринятоОт;
        Иначе
            СтрокаПозицииЧека.Наименование = НСтр("ru = 'Выдано:'")
                + " " + ДанныеДокумента.ПринятоОт;
        КонецЕсли;
        
        СтрокаПозицииЧека.Количество   = 1;
        СтрокаПозицииЧека.Цена         = ВыборкаАвансов.СуммаПереплаты;
        СтрокаПозицииЧека.Сумма        = ВыборкаАвансов.СуммаПереплаты;
        СтрокаПозицииЧека.СтавкаНДС    = РозничныеПродажиКлиентСервер.СтавкаНДСФискальнойОперации(ВыборкаАвансов.СтавкаНДС);
        СтрокаПозицииЧека.НомерСекции  = 2;
        
        Если СтрокаПозицииЧека.Количество <> 0 Тогда
            СтрокаПозицииЧека.ЦенаСоСкидками = Окр(СтрокаПозицииЧека.Сумма / СтрокаПозицииЧека.Количество, 2);
        КонецЕсли;
        
        ПозицииЧека.Добавить(СтрокаПозицииЧека);
        ИтогоСуммаЧека = ИтогоСуммаЧека + СтрокаПозицииЧека.Сумма;
        
    КонецЦикла;


=================================
Если аванс, то количество ставит "1". Почему ?
   Галахад
 
11 - 28.01.20 - 10:34
(10) А если теперь после отгрузки напечатать чек из реализации, что будет?
   Румата
 
12 - 28.01.20 - 10:44
(11) Попросил бухгалтера найти такие чеки, она сейчас освободиться - сбросит фотки
   Румата
 
13 - 28.01.20 - 12:11
На основании реализации из ПКО тоже печатается количество 1. Подозреваю, что аванс определяется по клиентской задолженности, а не по отдельному документу. У нас везде выбрано "частное лицо" в поле контрагент.
   victuan1
 
14 - 29.01.20 - 07:54
(10) Если в чеке указывается способ расчета = "Аванс", то в чеке не предусмотрено указывать наименование, кол-во и прочее согласно протокола ФФД, т.к. "аванс" используется ТОЛЬКО если это оплата, когда еще неизвестен предмет расчета (т.е. неизвестно, ЧТО именно купит покупатель).

Если предмет расчета известен, то в чеке вместо способа расчета "Аванс" необходимо использовать "Полная предоплата" или "Частичная предоплата".

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.