Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Отчет о невыполненных расчетах.

v7: Отчет о невыполненных расчетах.
Я
   JuixyJes
 
27.01.20 - 15:00
Доброго дня! Я тут отчетик делаю, но вот незадача, код вроде бы верный, все должно работать, нооо в цикл не попадаю впринципе

//*******************************************
Процедура Сформировать()
    //Построение отчета
    ЖрнКв = СоздатьОбъект("ЖурналРасчетов.Квартплата");
    асКлиенты = СоздатьОбъект("Справочник.Клиенты");
    НТП = ЖрнКв.НачалоТекущегоПериода();  
    КТП = ЖрнКв.КонецТекущегоПериода();
    ТабДок = СоздатьОбъект("Таблица");
    ТабДок.ИсходнаяТаблица("СписокРасчетовНеВып");
    ТабДок.ВывестиСекцию("Шапка");
    сч = 0;
    асКлиенты.ВыбратьЭлементы();
    Пока асКлиенты.ПолучитьЭлемент() = 1 Цикл
        Если (асКлиенты.ЭтоГруппа()=1) ИЛИ (асКлиенты.ПометкаУдаления()=1) ИЛИ (асКлиенты.ПринадлежитГруппе(ВЫБЫВШИЕ) = 1) Тогда
            Продолжить;
        КонецЕсли;
        сч = сч+1;
        лс = асКлиенты.ТекущийЭлемент().Код;
        Коммент ="";
        ЖрнКв.ВыбратьЗаписиПоОбъекту(асКлиенты,НТП,КТП);
        Пока ЖрнКв.ПолучитьЗапись() = 1 Цикл
            Если ЖрнКв.ВидРасч.ВходитВГруппу("ВсеНачисления") = 1 Тогда
                Если ЖрнКв.Результат = 0 Тогда
                    Коммент = Коммент + ЖрнКв.ВидРасч+ ", ";
                КонецЕсли;                                                                    
            КонецЕсли;
            Коммент = Лев(Коммент,СтрДлина(Коммент)-2);
        КонецЦикла;
        невыпрасч = Коммент;

        Если невыпрасч <> "" Тогда
            ТабДок.ВывестиСекцию("Строка");
        Иначе
            сч = сч - 1;
        КонецЕсли;
    КонецЦикла;
    ТабДок.Опции(0,0,3,0,0);
    ТабДок.ТолькоПросмотр(1);
    ТабДок.ПараметрыСтраницы(1,,,5,0,0,0,0,0,,,);
    ТабДок.Показать();
    //Построение отчета
КонецПроцедуры
   JuixyJes
 
1 - 27.01.20 - 15:01
ЖрнКв.ВыбратьЗаписиПоОбъекту(асКлиенты,НТП,КТП);       
Пока ЖрнКв.ПолучитьЗапись() = 1 Цикл

КонецЦикла;
   JuixyJes
 
2 - 27.01.20 - 15:02
По клиенту точно есть строки в журнале расчета.
   Масянька
 
3 - 27.01.20 - 15:05
(2) Текущий период?
   JuixyJes
 
4 - 27.01.20 - 15:06
период там 01.12.19 - 31.12.19
   JuixyJes
 
5 - 27.01.20 - 15:06
И записи за этот период есть
   Масянька
 
6 - 27.01.20 - 15:08
(5)   Пока асКлиенты.ПолучитьЭлемент() = 1 Цикл - сюда попадает?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.