Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Добавление в регистр данных

Добавление в регистр данных
Я
   example221
 
27.01.20 - 09:23
Альфа-Авто: Автосалон+Автосервис+Автозапчасти. Редакция 4.1 (4.1.01.28)
Обычный,база стоит на сервере
Доброе утро форумчане ,подскажите новичку,есть такое задание,надо добавить,в регистр новые автоработы(автозапчасти) по всем ТО Моделям и их кодам моделей
Набросал такой простенький интерфейс, https://pastenow.ru/3c9d439063f9bb50e1347bf6b077e527
В теории как я думал вот есть два поля автоработы и запчасти,те колонки поним добавляю в регистр,типо выбираю автоработу к ней привязан норматив и цена,а по колонке ТО модель и код он добавляет в регистр автоработу(запчасть)
подскажите как это можно реализовать.
   mpei
 
1 - 27.01.20 - 09:40
не очень понял тебе нужен код?

регистра какой сведений или накопления?
   example221
 
2 - 27.01.20 - 09:41
(1) Сведений,да какой нибудь намек как это должно выглядит гуглю уже полтора дня не могу понять
понятно дело что начинается как то так ,а дальше тупик
м_одель = новый Массив;
    Для каждого стр Из Модели Цикл
        Если стр.Пометка Тогда
            м_одель.Добавить(стр.Модель);
        КонецЕсли; 
    КонецЦикла;
    
    Для каждого стр Из ВидТО Цикл
        Если стр.Пометка Тогда
            м_одель.Добавить(стр.ВидТО);
        КонецЕсли; 
    КонецЦикла;
    
    Для каждого стр Из КодМодели Цикл
        Если стр.Пометка Тогда
            м_одель.Добавить(стр.КодМодели);
        КонецЕсли; 
    КонецЦикла;
    
    
    рег = РегистрыСведений.ПрайсМенюСервис.СоздатьМенеджерЗаписи();
    рег.ВидТО = стр.ВидТО;
    рег.Модель = стр.Модель;
    рег.КодМодели = стр.КодМодели
   mpei
 
3 - 27.01.20 - 09:49
А КодМодели и ВидТО это реквизиты модели?
   example221
 
4 - 27.01.20 - 09:52
(3) ВидТО КодМодели Модель и ТоварУслуга измерение регистра
   hhhh
 
5 - 27.01.20 - 10:06
(4) а где тут норматив и цена?
   example221
 
6 - 27.01.20 - 10:07
(5) Всмысле?,цену вводить человек будет в ручную,норматив тянется при добавление автоработы
   hhhh
 
7 - 27.01.20 - 10:13
(6) пока вообще непонятно, что делает эта программа из (2)
   example221
 
8 - 27.01.20 - 10:22
(7) Да мне подсказали что зря я все в один массив фигачу работать не будет,сказали табзнач сделать
   example221
 
9 - 27.01.20 - 10:24
(7) Есть форма со скрина,она работает как должна все норм,мне надо сделать так ,что бы добавляло автоработы(или запчасти) по всем моделям,кодамМоделей и видамТо(колонки).
   Momus
 
10 - 27.01.20 - 10:32
(9) в (2) добавить все в разные массивы и запись в регистр с двумя вложенными циклами
для каждого Модель из Модели Цикл
    для каждого ВидТО из ВидыТо Цикл
        Для каждого КодМодели Из КодыМОдели Цикл
            рег = РегистрыСведений.ПрайсМенюСервис.СоздатьМенеджерЗаписи();
            рег.ВидТО = ВидТО;
            рег.Модель = Модель;
            рег.КодМодели = КодМодели;
            рег.Записать();
       КонецЦикла;
   КонецЦикла;
КонецЦикла;

Ну и проверки всякие добавить
   example221
 
11 - 27.01.20 - 10:33
(9) Как заполнить колонки ТЗ данными с формы?
   example221
 
12 - 27.01.20 - 10:33
(10) Щас попробуй,спасиб
   example221
 
13 - 27.01.20 - 13:35
(10)Momus спасибо тебе огромное,чуть еще посидел,от твоего по делал,и вышло вроде как по плану,Спасибо огромное
вот итоговое
Массив2 = Новый Массив;
    Для каждого стр из ВидТО цикл
        Если стр.Пометка Тогда
            Массив2.Добавить(стр.ВидТО)
        КонецЕсли;
    КонецЦикла;
    
    Массив3 = Новый Массив;
    Для каждого стр из КодМодели цикл
        Если стр.Пометка тогда 
            Массив3.Добавить(стр.КодМодели)
        КонецЕсли;
    КонецЦикла;

    для каждого стр1 из Массив2 Цикл
        Для каждого стр2 Из Массив3 Цикл
            Для каждого стр3 из Авторабота цикл
                рег = РегистрыСведений.ПрайсМенюСервис.СоздатьМенеджерЗаписи();
                рег.ВидТО = стр1;
                рег.КодМодели = стр2;
                Рег.ТоварУслуга = стр3.АвтоРабота;
                Рег.Стоимость = стр3.цена;
                рег.Модель = стр2.Модель;
                рег.Записать();
            КонецЦикла;
            Для каждого стр4 из АвтоЗапчасти цикл
                рег1 = РегистрыСведений.ПрайсМенюСервис.СоздатьМенеджерЗаписи();
                рег1.ВидТО = стр1;
                рег1.КодМодели = стр2;
                Рег1.ТоварУслуга = стр4.Запчасть;
                Рег1.Стоимость = стр4.Цена*стр4.Количество;
                рег1.Модель = стр2.Модель;
                Рег1.Количество = стр4.Количество;
                рег1.Записать();
            КонецЦикла;
        КонецЦикла;
    КонецЦикла;
   example221
 
14 - 27.01.20 - 13:35
Закрыто.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.