Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при изменении колонки ТЧ дока внешней обработкой. В чем она?

Ошибка при изменении колонки ТЧ дока внешней обработкой. В чем она?
Я
   Обработка
 
06.11.19 - 16:32
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    
    Для Каждого Элемент из ОбъектыНазначенияМассив Цикл
        
        КлючПоиска = Новый Структура("Ключ", Элемент);
        
        Форма = ПолучитьФорму("Документ.ОтражениеЗарплатыВБухучете.Форма.ФормаДокумента",КлючПоиска);    
        Форма.ЭтотОбъект.Прочитать();
        НовыйОбъект = Форма.Объект;
        УдержаннаяЗарплата = Форма.УдержаннаяЗарплата;
        ЗаполнитьПитаниеСотрудников(НовыйОбъект,УдержаннаяЗарплата);
        КопироватьДанныеФормы(УдержаннаяЗарплата, Форма.УдержаннаяЗарплата);
        
    КонецЦикла;    
    
КонецПроцедуры

&НаСервере
// Функция заполнения питания по сотрудникам
//
Функция ЗаполнитьПитаниеСотрудников (Объект, УдержаннаяЗарплата )
    
    КонтрагентЗаПитание = Справочники.Контрагенты.НайтиПоНаименованию("ПитаниеСотрудников");    
    Для Каждого Строка из УдержаннаяЗарплата Цикл
        Если Строка.ВидОперации = Перечисления.ВидыОперацийПоЗарплате.ПрочиеУдержания Тогда    
            Строка.Контрагент = КонтрагентЗаПитание;
        КонецЕсли;    
    КонецЦикла;
    
    Возврат УдержаннаяЗарплата;
    
КонецФункции


пишет===
{ВнешняяОбработка.VED_ЗаполнитьПолучателяЗаПитание.Форма.Форма.Форма(11)}: Поле объекта не обнаружено (УдержаннаяЗарплата)
        УдержаннаяЗарплата = Форма.УдержаннаяЗарплата;
 
 
   vicof
 
1 - 06.11.19 - 16:35
У формы нет такого реквизита, как "удержаннаязарплата"
   Обработка
 
2 - 06.11.19 - 16:36
НО вот если эту внешнюю обработку делаю для отладки тестовой и с формы обработки заполняю все норм. Без ошибок но конечно не заполняется потому что форма то не открыта. Отлачдик норм проходит.

И при этом кнопку сделал и реквизит док соответствующего типа.

НаКлиенте
Процедура вып(Команда)
    // Вставить содержимое обработчика.

    КлючПоиска = Новый Структура("Ключ", док);
        
        Форма = ПолучитьФорму("Документ.ОтражениеЗарплатыВБухучете.Форма.ФормаДокумента",КлючПоиска);    
        Форма.ЭтотОбъект.Прочитать();
        НовыйОбъект = Форма.Объект;
        УдержаннаяЗарплата = НовыйОбъект.УдержаннаяЗарплата;
        ЗаполнитьПитаниеСотрудников(НовыйОбъект,УдержаннаяЗарплата);
        КопироватьДанныеФормы(УдержаннаяЗарплата, НовыйОбъект.УдержаннаяЗарплата);

КонецПроцедуры
   Обработка
 
3 - 06.11.19 - 16:39
(1)А как  мне отработать если на форме таблица -УдержаннаяЗарплата   имеет тип Объект.УдержаннаяЗарплата ?
   hhhh
 
4 - 06.11.19 - 16:43
(3) ну,

         УдержаннаяЗарплата = Форма.Объект.УдержаннаяЗарплата;
   bootini
 
5 - 06.11.19 - 16:43
(3) Так и отработать 
Для Каждого Строка ИЗ Объект.УдержаннаяЗарплата Цикл
   Обработка
 
6 - 06.11.19 - 16:46
(5) Я же работаю с формы объекта?
   bootini
 
7 - 06.11.19 - 16:47
(6) да как 4
   Обработка
 
8 - 06.11.19 - 16:51
ошибка у меня тут   ===  УдержаннаяЗарплата = Форма.УдержаннаяЗарплата;
   hhhh
 
9 - 06.11.19 - 16:53
(8) ну (4) же. Сам же говоришь, что УдержаннаяЗарплата это не реквизит формы
   Обработка
 
10 - 06.11.19 - 16:57
(9) да. Хоть убейте. Не могу сообразить.

Как находясь в форме дока вызвать обработку и что он просто одну колонку обработал и обновил.

Тупняк.
   bootini
 
11 - 06.11.19 - 16:59
(8) Дык это сразу было заметно ты же написал, что так не работает:
  УдержаннаяЗарплата = Форма.УдержаннаяЗарплата;

а так работает:
     НовыйОбъект = Форма.Объект;
     УдержаннаяЗарплата = НовыйОбъект.УдержаннаяЗарплата;
   Обработка
 
12 - 06.11.19 - 17:09
(11) Работает в режиме обычной обработки.
но как внешний с вызовом с формы нет.

УдержаннаяЗарплата = НовыйОбъект.УдержаннаяЗарплата; 

{ВнешняяОбработка.VED_ЗаполнитьПолучателяЗаПитание.Форма.Форма.Форма(13)}: Поле объекта не обнаружено (УдержаннаяЗарплата)
        КопироватьДанныеФормы(УдержаннаяЗарплата, Форма.УдержаннаяЗарпл
   bootini
 
13 - 06.11.19 - 17:11
Создание подключаемой обработки табличной части с диалогом запроса параметров заполнения (управляемые формы)
http://catalog.mista.ru/public/825702/
   sqr4
 
14 - 06.11.19 - 17:13
я владельца формы юзаю
   Обработка
 
15 - 06.11.19 - 17:22
спасибки покопаюсь. тут гулил не очень внятные вещи выши.
   Обработка
 
16 - 06.11.19 - 17:59
(13) Пример работает с объектом. А мне бы с формой и все.
Ну пусть объект заполняется но на форме должжен увидеть изенения и чтоб было моддифицированность.
   Обработка
 
17 - 07.11.19 - 07:00
так и не получилось  пока.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.