Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

А есть тут кто из Раруса?

А есть тут кто из Раруса?
Я
   Звездец
 
06.11.19 - 12:00
Чем больше приходится работать с конфигурациями раруса, тем меньше понимаю их. Они вообще проверяют что они пишут? Зато отраслевой ИТС подавай.
Что бы не быть голословным.

1с Учет в управл компаниях, ТСЖ, ЖКХ

01.01 делаем установку тарифа


допустим тариф изменился. из их сайта для изменения тарифа нужно ввести новый документ установка тарифа. но это не получится, так как в регистре сведений измерения Организация, тариф, вид тарифа и объект - а значит ошибка дубля записей.

отмена тарифа вообще песня. для отмены тарифа в сентябре, документ нужно провести датой установки тарифа.

и такой список могу продолжать долго очень.

уровень студента, только прочитавшего книгу Раченко, да и то не очень внимательно
 
 
   2S
 
1 - 06.11.19 - 12:02
(0) как может быть разный тариф в один день?
но конфа да, требует напильник, процентов 60% документов допиливали.
   Звездец
 
2 - 06.11.19 - 12:03
(1) а кто говорил про один день?
   2S
 
3 - 06.11.19 - 12:10
(2) что-то не то Вы говорите, тариф - периодический ресурс
   Звездец
 
4 - 06.11.19 - 12:13
да, но ошибка есть. Сейчас как раз разворачиваю копию
   HawkEye
 
5 - 06.11.19 - 12:14
(0) рарус никогда не отличался качеством кода....
   _Дайвер_
 
6 - 06.11.19 - 12:16
Если мсвПункты.Количество() Тогда
   ПробегСГрузом = мсвПуктны[0].Расстояние;
   ПробегСГрузом = мсвПуктны[0].Время;
КонецЕсли;

И это только цветочки, я УТ за эталон уже принимаю)))
   d4rkmesa
 
7 - 06.11.19 - 12:20
(0) Дык, что еще наваяют рабы на их галерах?
   d4rkmesa
 
8 - 06.11.19 - 12:20
Альфа авто еще не так плоха местами.
   Звездец
 
9 - 06.11.19 - 12:21
вот еще. Загрузка реестра платежей. Открыл выбрал папку откуда грузить. Этот путь программа запоминает. Если папку удалить - то больше обработка не откроется. Ну если вы проверяете наличие папки сохраненной, то уж обрабатывайте ее отсутствие [тут русская не нормативная лексика]
   _Дайвер_
 
10 - 06.11.19 - 12:22
А бесконечные проверки на лицензионность, практически при половине действий пользователя и вынос кода в двоичные данные... Буэээ
   Звездец
 
11 - 06.11.19 - 12:22
(10) говнокод надо защищать, представь если его тырить начнут )))
   2S
 
12 - 06.11.19 - 12:22
именно в ней "1с Учет в управл компаниях, ТСЖ, ЖКХ" меня вымораживала (ет) их неоперативность вывода изменений по ГИС ЖКХ, хотя как ГИС форматы клепал...
   Звездец
 
13 - 06.11.19 - 12:45
Зашибись

// Свертка ТЧ отключена, пока проверка уникальности выполняется средствами платформы

    // при записи данных в регистр сведений.

    
    //Если СписокОбъектов.Количество() > 0 Тогда

    //    Если (ВидОперации = Перечисления.УПЖКХ_ВидыОперацийУстановкиТарифов.УстановкаТарифа И УстанавливатьНаОбъекты)

    //     ИЛИ (ВидОперации = Перечисления.УПЖКХ_ВидыОперацийУстановкиТарифов.ОтменаТарифа И НЕ УстанавливатьНаОбъекты) Тогда

    //        СписокОбъектов.Свернуть("Здание, Помещение");

    //    Иначе

    //        СписокОбъектов.Очистить();

    //    КонецЕсли;

    //КонецЕсли;



ну вы там держитесь, а мы может когда-нибудь сделаем
   Звездец
 
14 - 06.11.19 - 12:57
прошел отладчиком и теперь вообще не понимаю. Получается периодичность не работает
Запись движений простейшая

Для Каждого ТекОбъект Из СписокОбъектов Цикл
                    Движение = Движения.КВП_Тарифы.Добавить();
                    Движение.Период      = Дата;
                    Движение.Организация = Организация;
                    Движение.Услуга      = Услуга;
                    Движение.Объект      = ?(ТекОбъект.Помещение.Пустая(), ТекОбъект.Здание, ТекОбъект.Помещение);
                    Движение.ВидТарифа   = ТекВидТарифа.ВидТарифа;
                    Движение.Тариф       = ТекВидТарифа.Тариф;
                    Движение.Действует   = Истина;
                КонецЦикла;
но не работает

Организация, услуга, объект и вид тарифа - совпадают, но период нет. И должно же записывать
   Звездец
 
15 - 06.11.19 - 13:06
так, ну тат разобрался. Немного еще и пользователи набахали, оказывается тариф они отменили ранее. Но все же, неужели нельзя рарусу сделать нормальную обработку элементарных ошибок?

Да и сам факт что отмена тарифа конфликтует с его назначением ...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.