Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отбор по группам в динамическом списке подбора

Отбор по группам в динамическом списке подбора
Я
   дущ1
 
05.11.19 - 20:30
УНФ 1.6
Стоит задача в подборе в дереве групп сделать видимыми для каждого пользователя только определенные группы.
Добавил расширение. В форму подбора следующее изменение

&НаСервере
Процедура изм_ПриСозданииНаСервереПеред(Отказ, СтандартнаяОбработка)
    Если РольДоступна("ПолныеПрава") Тогда //на время отладки, потом инвертировать
        ОсновнойСклад    = УправлениеНебольшойФирмойПовтИсп.ПолучитьЗначениеПоУмолчаниюПользователя(
            Пользователи.ТекущийПользователь(),    "ОсновнойСклад");
        СписокГрупп    = Новый СписокЗначений;
        Если СокрЛП(ОсновнойСклад.Код) = "НФ-000022" Тогда
            СписокГрупп.Добавить(Справочники.Номенклатура.НайтиПоКоду("00-00000909"));
        ИначеЕсли СокрЛП(ОсновнойСклад.Код) = "НФ-000020" Тогда
            СписокГрупп.Добавить(Справочники.Номенклатура.НайтиПоКоду("Н00000058"));
            СписокГрупп.Добавить(Справочники.Номенклатура.НайтиПоКоду("П00000709"));
        ИначеЕсли СокрЛП(ОсновнойСклад.Код) = "00-000002" Тогда
            СписокГрупп.Добавить(Справочники.Номенклатура.НайтиПоКоду("Е00000010"));
        КонецЕсли;
        
        ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(ЗапасыИерархия, "Ссылка", СписокГрупп, ВидСравненияКомпоновкиДанных.ВСпискеПоИерархии, , Истина, РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный);
    КонецЕсли;
КонецПроцедуры

В отладчике все прекрасно отрабатывает, но в форме отбор не ставится. Как я видел все группы, так и вижу. Что исправить что бы отрабатывало?
 
 
   дущ1
 
1 - 05.11.19 - 21:14
Тему можно закрыть.
У деревьев и иерархических списков в динамическом списке нельзя установить отбор. Только если ДС переводить в отображение = Список.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.