Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОбщаяФорма "ПечатьДокументов", в тонком клиенте все нормально, в веб - макеты без текста.

ОбщаяФорма "ПечатьДокументов", в тонком клиенте все нормально, в веб - макеты без текста.
Я
   SkillUp
 
05.11.19 - 13:12
Здравствуйте, В веб-клиенте, в общей форме -"ПечатьДокуметов", если выбрать документ, который надо распечатать. То он отображается с картинками и таблицами(рамки только), НО без текста. В тонком клиенте такого нету, и все работает как надо. При выборе документа для печтаи, отрбатывает единственная процедура (в форме) -"УстановитьТекущуюСтраницу()". Но, вот в тонком клиенте отлично все, а веб-клиенте без текста. Подскажите, из-за чего такое может быть? Или варианты, из-за чего такое происходит?

&НаКлиенте
Процедура УстановитьТекущуюСтраницу()

    НастройкаПечатнойФормы = ТекущаяНастройкаПечатнойФормы();
    ТекущаяСтраница = Элементы.СтраницаПечатнаяФормаНедоступна;
        
    Если НастройкаПечатнойФормы <> Неопределено Тогда
        ТД = НастройкаПечатнойФормы.спТабличныйДокумент[0].Значение;
        
        Если ТипЗнч(ТД) = Тип("ТабличныйДокумент") Тогда
            ТекущаяСтраница = Элементы.СтраницаТабличныйДокумент;
            ТабличныйДокумент = ТД;
        КонецЕсли;    
        
    КонецЕсли;
    
    Элементы.Страницы.ТекущаяСтраница = ТекущаяСтраница;
    
    ПереключитьПометкуКнопкиРедактирование();
    УстановитьДоступностьИзмененияМакета();
КонецПроцедуры

&НаКлиенте
Функция ТекущаяНастройкаПечатнойФормы()
    
    Результат = Элементы.НастройкиПечатныхФорм.ТекущиеДанные;
    Если Результат = Неопределено И НастройкиПечатныхФорм.Количество() > 0 Тогда
        Результат = НастройкиПечатныхФорм[0];
    КонецЕсли;
    Возврат Результат;
    
КонецФункции
 
 
   ИС-2
 
1 - 05.11.19 - 13:14
(0) попробовать другой браузер?
   SkillUp
 
2 - 05.11.19 - 13:14
(1) 1 мин.
   SkillUp
 
3 - 05.11.19 - 13:16
(1) Попробовал, не помогло.
   SkillUp
 
4 - 05.11.19 - 13:17
Нашел эту же процедуру, из другой конфигруации. Ничего принципиально ного не нашел...

&НаКлиенте
Процедура УстановитьТекущуюСтраницу()
    
    НастройкаПечатнойФормы = ТекущаяНастройкаПечатнойФормы();
    
    ТекущаяСтраница = Элементы.СтраницаПечатнаяФормаНедоступна;
    Если НастройкаПечатнойФормы <> Неопределено И ЭтотОбъект[НастройкаПечатнойФормы.ИмяРеквизита].ВысотаТаблицы > 0 Тогда
        ТекущаяСтраница = Элементы[НастройкаПечатнойФормы.ИмяСтраницы];
    КонецЕсли;
    
    Элементы.Страницы.ТекущаяСтраница = ТекущаяСтраница;
    
    ПереключитьПометкуКнопкиРедактирование();
    УстановитьДоступностьИзмененияМакета();
    
КонецПроцедуры
   SkillUp
 
5 - 05.11.19 - 13:19
Может какие-то проблемы с передачей табличного документа, на вебклиенте?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.