Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подключение адресного классификатора к реквизиту.

Подключение адресного классификатора к реквизиту.
Я
   JuixyJes
 
05.11.19 - 11:57
Доброго дня всем! Подскажите пожалуйста, как подключить адресный классификатор фиас к реквизиту "Адрес подразделения"?
 
 
   mistеr
 
1 - 05.11.19 - 12:02
Посмотреть в типовых и сделать так же.
   JuixyJes
 
2 - 05.11.19 - 12:03
Так-с а более подробные и понятные советы можно?:D
   SleepyHead
 
3 - 05.11.19 - 12:04
(2) Конечно. Обратитесь к программисту.
   JuixyJes
 
4 - 05.11.19 - 12:05
(3) Ахах. Спасибо за помощь, я вас поняла)
   SleepyHead
 
5 - 05.11.19 - 12:06
(4) а что тут смешного? Ответ в (1) вполне себе достаточен, учитывая уровень подробностей и понятности заданного вопроса.
   sqr4
 
6 - 05.11.19 - 12:18
https://its.1c.ru/db/bsp244doc#content:16:1
что то тут не густо)
   D_E_S_131
 
7 - 05.11.19 - 12:19
(6) А нужно потому что смотреть по подсистеме "Контактная информация".
   sqr4
 
8 - 05.11.19 - 12:20
(7) вот там да, что нужно
   JuixyJes
 
9 - 05.11.19 - 14:34
(8) как всегда помогаешь)) Спасибо большое, сейчас почитааааю.
   JuixyJes
 
10 - 06.11.19 - 09:30
Решила особо не заморачиваться)

&НаКлиенте
Процедура АдресПодразделенияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Структура =
    Форма = ОткрытьФорму("Обработка.РасширенныйВводКонтактнойИнформации.Форма.ГостиницаВводАдреса",Новый Структура("Представление",Объект.АдресПодразделения),Объект,,,, Новый ОписаниеОповещения("ВыборЗавершение", ЭтотОбъект),РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
КонецПроцедуры

Процедура ВыборЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    
    Если РезультатЗакрытия = Неопределено Тогда
        Сообщить("Адрес не указан.");
    Иначе
        Объект.АдресПодразделения = РезультатЗакрытия.Представление;
    КонецЕсли;
    
КонецПроцедуры
   JuixyJes
 
11 - 06.11.19 - 09:32
Но тут встал вопрос! Мне бы структуру, которая в РезультатЗакрытия попадает, получить в процедуру АдресПодразделенияНачалоВыбора(), чтоб передавать как параметр открытия формы.
   sqr4
 
12 - 06.11.19 - 09:41
(11) а смысл? Форма не заполненная открывается? Может стоит заморочаться?
   RomaH
 
13 - 06.11.19 - 09:43
   JuixyJes
 
14 - 06.11.19 - 09:55
(12) именно, не заполненная открывается. передавая просто структуру 
 Новый Структура("Представление",Объект.АдресПодразделения)
открывается форма с вводом "свободным" адреса. Заморачиваться не охото, ахах, структура вроде как та, что нужно) Просто подскажите как ее вернуть в процедуру из ВыборЗавершение в АдресПодразделенияНачалоВыбора
   JuixyJes
 
15 - 06.11.19 - 10:06
Не охото прибегать к БСП, к тому же структура в Результат закрытия подается та же, что и в сведениях об организации
   JuixyJes
 
16 - 06.11.19 - 10:07
+ (15) в сведениях об организации подается в параметры при создании на сервере.
   acht
 
17 - 06.11.19 - 10:14
(15) Я было захотел тебе помочь, но что-то заморачиваться не охото, ахах, структура вроде как та. Посижу, подожду, вдруг само напишется?
А, еще смайлик забыл. Вот он )
   JuixyJes
 
18 - 06.11.19 - 10:18
(17) ха-ха, смешно) Ну серьезно. Как получить можно структуру?
   JuixyJes
 
19 - 06.11.19 - 10:36
(17) Структура не вроде как, а точно такая, как надо. Но как ее получить, не понимаю.
   SleepyHead
 
20 - 06.11.19 - 11:01
(19) см (3)
   JuixyJes
 
21 - 06.11.19 - 11:48
(20) Да, да. Я бы сказала пару ласковых  в сторону таких диванных экспертов, да не буду. Вы если помочь не хотите разобраться человеку что к чему, то промолчите)
   SleepyHead
 
22 - 06.11.19 - 17:35
(21) вам уже все разжевали, вы все равно не понимаете.  Остаётся надеяться, что хотя бы готовите вкусно.
   МимохожийОднако
 
23 - 06.11.19 - 17:47
(15) "Не охото прибегать к БСП" - зря


Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.