Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как отловить событие на форме владельца кнопки Создать на основании?

Как отловить событие на форме владельца кнопки Создать на основании?
Я
   AlexandrNovicov
 
01.11.19 - 07:58
Иногда в спешке, нажимая на кнопку Создать на основании, получается не желательный результат:

Пример:
Создал расходную накладную, заполнил её и жму создать на основании, меня система предупреждает о том что форма модифицирована (где описано это событие?)
Система сообщает только о модифицированности формы, но не проверяет проведен ли объект, вот и получается что я могу СоздатьРКО(выбить чек) на основании непроведённого документа, что не является желаемым результатом.
Может где-то флаг есть "создавать на основании не проведенного", Управление сервисным центром, редакция 1.6 (1.6.16.176), 1С:Предприятие 8.3 (8.3.15.1700)

Спасибо
 
 
   _stay true_
 
1 - 01.11.19 - 08:02
(0)
Процедура "ОбработкаЗаполнения" в модуле объекта РКО.
Там можно сделать проверку типа "Если Не Основание.Проведен" Тогда..." 

Ну эт царь-костыль, когда остальное не работает
   Cyberhawk
 
2 - 01.11.19 - 08:31
Вот поэтому платформенные кнопки в типовых на БСП загашены и вместо них свои
   PaulBC
 
3 - 01.11.19 - 08:36
(0) Если кнопка создается программно, как в УТ/КА/ЕРП, то
КомандаСоздатьНаОсновании.РежимЗаписи = "Проводить"; в ДобавитьКомандуСоздатьНаОсновании(КомандыСоздатьНаОсновании)
   AlexandrNovicov
 
4 - 01.11.19 - 13:08
Через расширение (Дополнение) сделал:


&Перед("ОбработкаЗаполнения")
Процедура Дополнение_ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.РасходнаяНакладная") Тогда
        Если НЕ ДанныеЗаполнения.Проведен тогда
            ДокументПроведение = ДанныеЗаполнения.ПолучитьОбъект();
            ДокументПроведение.Записать(РежимЗаписиДокумента.Проведение);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.