Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Совершенные числа, исправить(доработать) программу

Совершенные числа, исправить(доработать) программу
Я
   ДядяДеда
 
30.10.19 - 20:26
Задача "Совершенные числа".                                
Число называется совершенным, если оно равно сумме всех своих делителей, меньших его самого.                                
1  Вычислить программно и вывести на форму первые 3 совершенных числа.                                
2 Определить, является ли указанное пользователем число совершенным.                                

&НаКлиенте
Процедура СовершенныеЧислаОткрытие()
    НачальноеЧисло = 2;
    ПределПоиска = 500;
    
    Пока НачальноеЧисло < ПределПоиска Цикл
        СуммаДелителей = 0;
        Делитель = 1;
        
        Пока Делитель <= НачальноеЧисло/2 Цикл
            Если НачальноеЧисло % Делитель = 0 Тогда
            СуммаДелителей = СуммаДелителей + Делитель;
        КонецЕсли;
        Делитель = Делитель +1;
        КонецЦикла;
        
        Если СуммаДелителей = НачальноеЧисло Тогда
            СовершенныеЧисла = НачальноеЧисло;
        КонецЕсли;
        НачальноеЧисло = НачальноеЧисло + 1;
    КонецЦикла;
    
    КонецПроцедуры
 
 
   Изучаю1С8
 
1 - 30.10.19 - 20:34
(0) Сколько платите?
   ДядяДеда
 
2 - 30.10.19 - 20:36
(1) За интерес, мне кажется для вас работы на 2 минуты
   Консультант Баранов
 
3 - 30.10.19 - 20:37
Помогите накидать программку которая доказывает

Для любого положительного (не обязательно целого) числа s>1 есть только КОНЕЧНОЕ число взаимнопростых троек A, B, С, таких, что A+B=C и

rad(ABC)^s < C
   Доминошник
 
4 - 30.10.19 - 20:39
(0) И где, собственно, вывод?
Где определение - какое по счёту совершенное число найдено (и если найдено третье - то пора останавливаться).

По-хорошему - нужна функция, в которую передаём "анализируемое число", а из неё получаем ответ - совершенное ли число или нет.
Эта же функция будет востребована при части 2 данной задачи.
   ДядяДеда
 
5 - 30.10.19 - 21:21
(4) вот это все я и не знаю как сделать ?
   ДядяДеда
 
6 - 31.10.19 - 11:12
(4) Можете посоветовать материал для прочтения с помощью которого можно будет решить эту задачу ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.