Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как заполнить результатом выборки Реквизит обработки

Как заполнить результатом выборки Реквизит обработки
Я
   sasha-asn
 
30.10.19 - 15:37
Здравствуйте уважаемые эксперты, как юный подаван прошу вашей Великой помощи! Подскажите пожалуйста!

Я написал запрос, он должен выгружать номер телефона из регистра сведений КонтактнаяИнформация.Представление в реквизит обработки когда я выбираю Ответственного. Отладчиком вижу что номер подхватывает правильно. Запрос отрабатывает, но данные не выгружаются в реквизит.

вот запрос и Процедура ПриИзменении Ответственного:
-------------------------------------------------------------------------------
Функция ОпределитьТелОтветственного(Пользователь)
    З = Новый Запрос;
    З.Текст = "ВЫБРАТЬ
              |    КонтактнаяИнформация.Представление
              |ИЗ
              |    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
              |ГДЕ
              |    КонтактнаяИнформация.Объект = &Объект
              |    И КонтактнаяИнформация.Тип = &Тип";
              
    З.УстановитьПараметр("Тип",Перечисления.ТипыКонтактнойИнформации.Телефон);
    З.УстановитьПараметр("Объект",Пользователь);

    Выб  = З.Выполнить().Выбрать();
    Если Выб.Следующий() Тогда
       Возврат Выб.Представление;
    КонецЕсли;    
КонецФункции    

    
Процедура ОтветственныйПриИзменении(Элемент)

Пользователь = ПараметрыСеанса.ТекущийПользователь;    
ОпределитьТелОтветственного(Пользователь);

КонецПроцедуры

-------------------------------------------------------------------------------
 
 
   Михаил Козлов
 
1 - 30.10.19 - 15:48
Функция Вам вернула значение, но Вы его не используете (не присваиваете реквизиту обработки).
   sasha-asn
 
2 - 30.10.19 - 15:51
Спасибо!
ТелефонОтветственного = ОпределитьТелОтветственного(Пользователь);
   Rovan
 
3 - 30.10.19 - 16:23
странно... поле Ответственный, а телефон берут у Текущего пользователя

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.