Вход | Регистрация
 

При открытии диалога выбора файла, вайл эксель не отображается в каталоге

При открытии диалога выбора файла, вайл эксель не отображается в каталоге
Я
   LivingStar
 
30.10.19 - 07:14
Делаю диалог выбора эксель файла. Но в режиме предприятия при его открытии сам файл не виден в каталоге.
Подскажите пожалуйста, что не так?

Процедура ЗагружаемыйФайлНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    ДиалогОткрытия                    = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогОткрытия.ПолноеИмяФайла     = "";
    ДиалогОткрытия.Фильтр               = "Файлы Excel (*.xls|*.xlsx)|*.xl*";
    ДиалогОткрытия.МножественныйВыбор = Ложь;
    ДиалогОткрытия.Заголовок          = "Выберите файл Excel";
    Если ДиалогОткрытия.Выбрать() Тогда
        МассивВыбранныхФайлов = ДиалогОткрытия.ВыбранныеФайлы;
        Для Каждого ИмяВыбранногоФайла Из МассивВыбранныхФайлов Цикл
            ВыбранныйФайл = Новый Файл(ИмяВыбранногоФайла);
            Сообщить(ИмяВыбранногоФайла + "; Размер = " + ВыбранныйФайл.Размер());
        КонецЦикла;
    Иначе
        Предупреждение("Нет выбранных файлов!");
    КонецЕсли;
КонецПроцедуры
 
 
   ДенисЧ
 
1 - 30.10.19 - 07:21
ДиалогОткрытия.Фильтр               = "Файлы Excel (*.xls,*.xlsx)|*.xl*";
   LivingStar
 
2 - 30.10.19 - 07:23
Что не так вот в этой строке?

    ДиалогОткрытия.Фильтр               = "Файлы Excel (*.xls|*.xlsx)|*.xls;*.xlsx|";
   LivingStar
 
3 - 30.10.19 - 07:24
(1) Ок! Спасибо. Ваш вариант рабочий!
   ДенисЧ
 
4 - 30.10.19 - 07:27
(3) Естественно
   Fram
 
5 - 30.10.19 - 07:31
(4) ты решил, что проще сразу писать ему рабочий код? )
   ДенисЧ
 
6 - 30.10.19 - 08:43
(5) Изабелл он меня уже. Дольше объяснять.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.