Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Недопустимое значение параметра (параметр номер '1')

Недопустимое значение параметра (параметр номер '1')
Я
   Папай
 
29.10.19 - 18:13
Добрый день.Замучался немного с планировщиком.такой вопрос появилась ошибка
Ошибка при вызове метода контекста (Добавить)
            НовыйМастер = ИзмерениеМастера.Элементы.Добавить(выб.Мастер);
по причине:
Недопустимое значение параметра (параметр номер '1')


&НаКлиенте
Процедура Отобразить(Команда)
    Планировщик.ТекущиеПериодыОтображения.Очистить();
//Планировщик.ТекущиеПериодыОтображения.Добавить(ПериодОтображенияНачало, ПериодОтображенияКонец);
Планировщик.ТекущиеПериодыОтображения.Добавить(НачалоДня(Текущаядата()), КонецДня(Текущаядата()));
Планировщик.ЕдиницаПериодическогоВарианта = ТипЕдиницыШкалыВремени.Час;
Планировщик.КратностьПериодическогоВарианта = 24;
Планировщик.ОтображатьПеренесенныеЗаголовки = Истина;
Планировщик.ОтступСНачалаПереносаШкалыВремени=8;
Планировщик.ОтступСКонцаПереносаШкалыВремени=3;


    // Инициализируем измерения планировщика
    ИзмеренияПланировщика   = Планировщик.Измерения;
    ИзмеренияПланировщика.Очистить();

  
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Заявка.Ссылка КАК Ссылка,
        |    Заявка.Мастер КАК Мастер,
        |    Заявка.ДатаНачала КАК ДатаНачала,
        |    Заявка.ДатаОкончания КАК ДатаОкончания
        |ИЗ
        |    Документ.Заявка КАК Заявка
        |ГДЕ
        |    ЗаявкаНаРемонтСокр.Дата МЕЖДУ &ДатаНачало И &ДатаКонец";
        
        Запрос.УстановитьПараметр("ДатаНачало",НачалоГода(Текущаядата()));
        Запрос.УстановитьПараметр("ДатаКонец", КонецДня(Текущаядата()));
        выб = Запрос.Выполнить().Выбрать();
        
        ИзмерениеМастера       = ИзмеренияПланировщика.Добавить("Мастера");
    
        Пока выб.Следующий() Цикл
            // Заполнение измерений продавцы
            НовыйМастер = ИзмерениеМастера.Элементы.Добавить(выб.Мастер);
            НовыйМастер.Текст = выб.Мастер.Наименование;
        
        КонецЦикла;
 
 
   Папай
 
1 - 29.10.19 - 18:14
работало только через таблицу значение:
        //ТЗ=Запрос.Выполнить().Выгрузить();

        //ТЗ.Свернуть("Мастер");


        //для каждого стр из ТЗ Цикл

        //    // Заполнение измерений продавцы

        //    НовыйМастер = ИзмерениеМастера.Элементы.Добавить(стр.Мастер);

        //    НовыйМастер.Текст = стр.Мастер;

        //КонецЦикла;


так работало
   acht
 
2 - 29.10.19 - 19:21
(0) Дубли?
   ДенисЧ
 
3 - 29.10.19 - 19:35
Если ИзмерениеМастера.Элементы.Найти(выб.Мастер, = Неопределено Тогда
 НовыйМастер = ИзмерениеМастера.Элементы.Добавить(выб.Мастер);
Иначе
  Сообщить("А такой " + выб.Мастер + " уже планирует, как та белка...");
КонецЕсли;
   acht
 
4 - 29.10.19 - 19:53
(3) Экий затейник...

ВЫБРАТЬ РАЗЛИЧНЫЕ Мастер, Мастер.Наименование ИЗ
   ДенисЧ
 
5 - 29.10.19 - 19:57
(4) А ссылки ты зачем буков Х накрыл? Если выбирались, значит, были нужны. Да и даты тоже для планировщика как бе...
Я ж не вникаю в приведённый кусок кода, явно не полный...
   acht
 
6 - 29.10.19 - 20:06
(5) Хрен его знает. Судя по комментарию "Заполнение измерений продавцы" и выборкой мастеров - там вообще что-то ядреное, разуму нашему неподвластное.

Это уж пусть ТС сам.
   AlvlSpb
 
7 - 29.10.19 - 21:50
(0) Недопустимое значение параметра . Сравни  со своим http://catalog.mista.ru/public/997060/

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.